summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2020-09-22 23:59:01 +0200
committerMichal Wojdyla2020-09-22 23:59:01 +0200
commit893a668c1d0a1ab2501efbbbeb43f173700402e9 (patch)
tree03fd680214031adbcb1625a817113a94360bdfe2
parentb885d68aad7def7e49a67fd9070614112f61b7f4 (diff)
downloadaur-893a668c1d0a1ab2501efbbbeb43f173700402e9.tar.gz
update to 2.12
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
2 files changed, 25 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5913bc034419..64af03f996a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
pkgbase = thunderbird-tbsync
pkgdesc = Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV
- pkgver = 0.7.11
+ pkgver = 2.12
pkgrel = 1
url = https://github.com/jobisoft/TbSync
arch = any
groups = office
- license = GPL3
- makedepends = zip
- depends = thunderbird>=50
- depends = thunderbird<61
- provides = tbsync=0.7.11
+ license = MPL-2.0
+ depends = thunderbird>=68
+ depends = thunderbird<69
+ provides = tbsync=2.12
conflicts = thunderbird-tbsync-beta
- replaces = thunderbird-tbsync-beta
- options = !strip
- options = !libtool
- options = !staticlibs
- options = !docs
- source = thunderbird-tbsync-0.7.11.xpi::https://github.com/jobisoft/TbSync/releases/download/v0.7.11/TbSync-0.7.11.xpi
- sha256sums = 04ae3b66ce85ea4cd0d78fd3c48a7b8a9f6919897c06c97ee80db6c5faa6a254
+ noextract = tbsync-2.12-tb.xpi
+ source = https://addons.thunderbird.net/thunderbird/downloads/file/1016743/tbsync-2.12-tb.xpi
+ sha256sums = d7e28222b569b50d6e624c8a6cfa1808956b8b8e0c64211d03fabf8d5acd857a
pkgname = thunderbird-tbsync
diff --git a/PKGBUILD b/PKGBUILD
index 152cbc9b6897..44ca168a97dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,26 @@
-# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com>
+# Contributor: Javier Tiá <javier dot tia at gmail dot com>
-_name=tbsync
-_name_ext=TbSync
-pkgname=thunderbird-${_name}
-pkgver=0.7.11
+pkgname=thunderbird-tbsync
+pkgver=2.12
pkgrel=1
-pkgdesc='Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV'
-url='https://github.com/jobisoft/TbSync'
+_file=1016743
+_name=tbsync
+pkgdesc="Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV"
arch=('any')
+url="https://github.com/jobisoft/TbSync"
+license=('MPL-2.0')
groups=('office')
-license=('GPL3')
-depends=('thunderbird>=50' 'thunderbird<61')
+depends=('thunderbird>=68' 'thunderbird<69')
conflicts=("${pkgname}-beta")
-replaces=("${pkgname}-beta")
-makedepends=('zip')
-options=('!strip' '!libtool' '!staticlibs' '!docs')
provides=("${_name}=${pkgver}")
-source=("${pkgname}-${pkgver}.xpi::${url}/releases/download/v${pkgver}/${_name_ext}-${pkgver}.xpi")
-sha256sums=('04ae3b66ce85ea4cd0d78fd3c48a7b8a9f6919897c06c97ee80db6c5faa6a254')
+# https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/versions/
+source=("https://addons.thunderbird.net/thunderbird/downloads/file/$_file/$_name-$pkgver-tb.xpi")
+noextract=("$_name-$pkgver-tb.xpi")
+sha256sums=('d7e28222b569b50d6e624c8a6cfa1808956b8b8e0c64211d03fabf8d5acd857a')
package() {
- _extdir=usr/lib/thunderbird/extensions
- mkdir -p ${pkgdir}/${_extdir}/${pkgname}
- cd ${pkgdir}/${_extdir}/${pkgname}
- bsdtar -x -f ${srcdir}/${pkgname}-${pkgver}.xpi
-
- # Extract extension name
- _emid=$(grep -m 1 em:id install.rdf | sed 's/.*>\(.*\)<.*/\1/')
-
- # Change extension name
- cd ..
- mv ${pkgname} ${_emid}
- cd ${_emid}
-
- # Fix permissions in emid extension directory
- find . -type d -exec chmod 0755 \{\} \+
- find . -type f -exec chmod 0644 \{\} \+
- chown -R root:root .
+ _extension_id="tbsync@jobisoft.de"
+ _extension_dest="${pkgdir}/usr/lib/thunderbird/extensions/${_extension_id}"
+ install -Dm644 "${srcdir}"/$_name-$pkgver-tb.xpi "${_extension_dest}.xpi"
}
-
-# vim:set ft=sh ts=2 sw=2 ft=sh et: