summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2018-08-17 11:27:37 -0600
committerJavier Tiá2018-08-17 11:27:37 -0600
commitcb7c3146a80f9b768b90f8c0325018765b53e344 (patch)
tree625b0b41d1532b5dfe165985087dbefa3b70f05f
downloadaur-cb7c3146a80f9b768b90f8c0325018765b53e344.tar.gz
Bump up thunderbird-tbsync 0.7.10-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c43537187657
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = thunderbird-tbsync
+ pkgdesc = Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV
+ pkgver = 0.7.10
+ pkgrel = 1
+ url = https://github.com/jobisoft/TbSync
+ arch = any
+ groups = office
+ license = GPL3
+ makedepends = zip
+ depends = thunderbird>50
+ depends = thunderbird<=61
+ provides = tbsync=0.7.10
+ options = !strip
+ options = !libtool
+ options = !staticlibs
+ options = !docs
+ source = thunderbird-tbsync-0.7.10.xpi::https://github.com/jobisoft/TbSync/releases/download/v0.7.10/TbSync-0.7.10.xpi
+ sha256sums = c078f7879eeed853cd772622ea4354bea472cddf73b454300173a3e7d2b48623
+
+pkgname = thunderbird-tbsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64cc52a7e410
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+
+_name=tbsync
+_name_ext=TbSync
+pkgname=thunderbird-${_name}
+pkgver=0.7.10
+pkgrel=1
+pkgdesc='Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV'
+url='https://github.com/jobisoft/TbSync'
+arch=('any')
+groups=('office')
+license=('GPL3')
+depends=('thunderbird>=50' 'thunderbird<=61')
+makedepends=('zip')
+options=('!strip' '!libtool' '!staticlibs' '!docs')
+provides=("${_name}=${pkgver}")
+source=("${pkgname}-${pkgver}.xpi::${url}/releases/download/v${pkgver}/${_name_ext}-${pkgver}.xpi")
+sha256sums=('c078f7879eeed853cd772622ea4354bea472cddf73b454300173a3e7d2b48623')
+
+package() {
+ _extdir=usr/lib/thunderbird/extensions
+ mkdir -p ${pkgdir}/${_extdir}/${pkgname}
+ cd ${pkgdir}/${_extdir}/${pkgname}
+ bsdtar -x -f ${srcdir}/${pkgname}-${pkgver}.xpi
+
+ # Extract extension name
+ _emid=$(grep -m 1 em:id install.rdf | sed 's/.*>\(.*\)<.*/\1/')
+
+ # Change extension name
+ cd ..
+ mv ${pkgname} ${_emid}
+ cd ${_emid}
+
+ # Fix permissions in emid extension directory
+ find . -type d -exec chmod 0755 \{\} \+
+ find . -type f -exec chmod 0644 \{\} \+
+ chown -R root:root .
+}
+
+# vim:set ft=sh ts=2 sw=2 ft=sh et: