summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2018-08-20 08:59:31 -0600
committerJavier Tiá2018-08-20 08:59:31 -0600
commit785518e3ff9a383866739e4e7ea5cb5ef4c0f5d1 (patch)
tree9a3c1ccf3eeb81b0fd2869f0fea6add68b0ce649
downloadaur-785518e3ff9a383866739e4e7ea5cb5ef4c0f5d1.tar.gz
Bump up thunderbird-tbsync-beta 0.7.10.26-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57cb2f995413
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = thunderbird-tbsync-beta
+ pkgdesc = Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV
+ pkgver = 0.7.10.26
+ pkgrel = 1
+ url = https://github.com/jobisoft/TbSync
+ arch = any
+ groups = office
+ license = GPL3
+ makedepends = zip
+ depends = thunderbird>=50
+ depends = thunderbird<61
+ provides = tbsync=0.7.10.26
+ options = !strip
+ options = !libtool
+ options = !staticlibs
+ options = !docs
+ source = thunderbird-tbsync-beta-0.7.10.26.xpi::https://github.com/jobisoft/TbSync/releases/download/v0.7.10/TbSync-beta.xpi
+ sha256sums = 9e10dc88d87b33161af0789e9825b8d4bcccb4c5211dfe86c5e31c8c66f8fd52
+
+pkgname = thunderbird-tbsync-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90ee2cf35d73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+
+_name=tbsync
+_name_ext=TbSync
+pkgname=thunderbird-${_name}-beta
+_ver=0.7.10
+pkgver=0.7.10.26
+pkgrel=1
+pkgdesc='Sync contacts, tasks and calendars to thunderbird using Exchange ActiveSync (EAS) and CalDAV/CardDAV'
+url='https://github.com/jobisoft/TbSync'
+arch=('any')
+groups=('office')
+license=('GPL3')
+depends=('thunderbird>=50' 'thunderbird<61')
+makedepends=('zip')
+conflict=("thunderbird-${_name}")
+replace=("thunderbird-${_name}")
+options=('!strip' '!libtool' '!staticlibs' '!docs')
+provides=("${_name}=${pkgver}")
+source=("${pkgname}-${pkgver}.xpi::${url}/releases/download/v${_ver}/${_name_ext}-beta.xpi")
+sha256sums=('9e10dc88d87b33161af0789e9825b8d4bcccb4c5211dfe86c5e31c8c66f8fd52')
+
+package() {
+ _extdir=usr/lib/thunderbird/extensions
+ mkdir -p ${pkgdir}/${_extdir}/${pkgname}
+ cd ${pkgdir}/${_extdir}/${pkgname}
+ bsdtar -x -f ${srcdir}/${pkgname}-${pkgver}.xpi
+
+ # Extract extension name
+ _emid=$(grep -m 1 em:id install.rdf | sed 's/.*>\(.*\)<.*/\1/')
+
+ # Change extension name
+ cd ..
+ mv ${pkgname} ${_emid}
+ cd ${_emid}
+
+ # Fix permissions in emid extension directory
+ find . -type d -exec chmod 0755 \{\} \+
+ find . -type f -exec chmod 0644 \{\} \+
+ chown -R root:root .
+}
+
+# vim:set ft=sh ts=2 sw=2 ft=sh et: