summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:24 +0200
committerMuflone2015-06-13 17:59:24 +0200
commitcf30ab0e30755480c180c8b9cb03377c9584f943 (patch)
tree25159700f22ce402ec3d14ee84a6a673945185c1
downloadaur-cf30ab0e30755480c180c8b9cb03377c9584f943.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20d40f21d527
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = thunderbird-theme-adwaita
+ pkgdesc = Adwaita theme for Thunderbird (Matches the default Gnome Shell theme)
+ pkgver = 31.0
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/thunderbird/addon/adwaita-thunderbird
+ arch = any
+ license = MPL
+ makedepends = unzip
+ depends = thunderbird
+ source = thunderbird-theme-adwaita-31.0.zip::https://github.com/gnome-integration-team/thunderbird-gnome/archive/0284aedcc3c6ca908e1083647ab4589c2bbd84be.zip
+ sha256sums = b0bf6b5ebb6942af16d09696684d95d924e69b0980b15ae4de76e54b8704cb01
+
+pkgname = thunderbird-theme-adwaita
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdeb59522ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Diego Principe <cdprincipe@at@gmail@dot@com>
+
+pkgname=thunderbird-theme-adwaita
+pkgver=31.0
+pkgrel=1
+pkgdesc="Adwaita theme for Thunderbird (Matches the default Gnome Shell theme)"
+url="https://addons.mozilla.org/en-US/thunderbird/addon/adwaita-thunderbird"
+arch=('any')
+license=('MPL')
+depends=("thunderbird")
+makedepends=('unzip')
+_git_commit="0284aedcc3c6ca908e1083647ab4589c2bbd84be"
+source=("${pkgname}-${pkgver}.zip"::"https://github.com/gnome-integration-team/thunderbird-gnome/archive/${_git_commit}.zip")
+sha256sums=('b0bf6b5ebb6942af16d09696684d95d924e69b0980b15ae4de76e54b8704cb01')
+
+package() {
+ cd "${srcdir}/thunderbird-gnome-${_git_commit}/theme"
+ # Find extension UUID
+ _emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ # Prepare destination folder
+ _dstdir="${pkgdir}/usr/lib/thunderbird/extensions/${_emid}"
+ install -d "${_dstdir}"
+ # Copy files
+ cp -R * "${_dstdir}"
+ # Restore standard permissions
+ find "${pkgdir}" -type d -print0 | xargs --null chmod 0755
+ find "${pkgdir}" -type f -print0 | xargs --null chmod 0644
+}
+
+