summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:39:21 +0200
committerXZS2016-04-22 11:39:21 +0200
commit0b090ff52e256374a9111d7d036a2b21fd4d100e (patch)
tree672933afce90b26157b0aba81659c99009cb7dd5
parenta3a3fdf81d79de502d5122377a22c0f8feee7faf (diff)
downloadaur-0b090ff52e256374a9111d7d036a2b21fd4d100e.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f87c4eb26607..757bab6fbd43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,8 +76,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- install -d "$destdir/$id"
- cp --no-preserve=ownership,mode -r * "$destdir/$id"
+ cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ find "$destdir/$id" -mindepth 1 -name ".*" -exec rm -rf '{}' +
}
# Hidden from mksrcinfo in silly subfunction.