summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:30:11 +0100
committerXZS2016-10-31 18:30:11 +0100
commit2d9d993e40f7c60d02ea877253c567968ec6080b (patch)
tree4516965ca3095cee99cd8240425b87ea9a694250
parent9854f806156a48f69cce008a0729fe069be0d185 (diff)
downloadaur-2d9d993e40f7c60d02ea877253c567968ec6080b.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c09edeef5d1..53cab4cb3771 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thunderbird-theme-tt-deepdark
pkgdesc = Smooth dark theme for Thunderbird
pkgver = 11.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/thunderbird/addon/tt-deepdark/
arch = any
license = custom:noncommercial
diff --git a/PKGBUILD b/PKGBUILD
index 6a047cd5c94d..36af7cd33de5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=thunderbird-theme-tt-deepdark
pkgver=11.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Smooth dark theme for Thunderbird'
license=('custom:noncommercial')
md5sums=('ab004efa182865052f073d26ac10593e')
@@ -41,9 +41,18 @@ query-version() {
xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {