summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-20 18:40:19 +0200
committerXZS2016-04-20 18:40:19 +0200
commita3a3fdf81d79de502d5122377a22c0f8feee7faf (patch)
tree5e0f889b890489e14d5459758ece3c9fdb0fd7f7
parentf8e2788a5175ea041b8f01030435643a11558b95 (diff)
downloadaur-a3a3fdf81d79de502d5122377a22c0f8feee7faf.tar.gz
omit hidden files
Hidden files are normally only used to manage the source code of the extension. They are not needed in and have no direct relation to the compiled package and can thus be left out safely. At this moment, there are no hidden files in this extension. So this change happens just in anticipation to future additions and not raising the need to increment the pkgrel.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d52879cc4bbc..f87c4eb26607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,7 +76,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ install -d "$destdir/$id"
+ cp --no-preserve=ownership,mode -r * "$destdir/$id"
}
# Hidden from mksrcinfo in silly subfunction.