summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-10-15 01:22:25 +0200
committerXZS2015-10-15 01:22:25 +0200
commitd725989fd89cf1522d2ce4276053a75f4d666915 (patch)
tree6a466400cc6a57512e637f25fdaf66663c9c8184
parent6d5595ef81a75870a377fd490e96209e4b9a6f07 (diff)
downloadaur-d725989fd89cf1522d2ce4276053a75f4d666915.tar.gz
ask addons.mozilla.org for updated information
The addons.mozilla.org API provides updated information about Add-On compatibility more recent than the install.rdf file included in the extension. Restricting package relations according to it yields a wider version range, especially with newer versions.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b958ecc78391..d6bbab9c645a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,9 @@ pkgbase = thunderbird-theme-tt-deepdark
makedepends = rasqal
depends = thunderbird
source = thunderbird-theme-tt-deepdark.zip::https://addons.mozilla.org/firefox/downloads/latest/tt-deepdark/platform:2/
+ source = version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/tt-deepdark
md5sums = 3885774cdb2aaa33494002b1a2703ae1
+ md5sums = SKIP
pkgname = thunderbird-theme-tt-deepdark
diff --git a/PKGBUILD b/PKGBUILD
index 1270cdd9db0b..d52879cc4bbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,11 @@ md5sums=('3885774cdb2aaa33494002b1a2703ae1')
[ "$arch" ] || arch=('any')
-source+=("${pkgname}.zip::https://addons.mozilla.org/firefox/downloads/latest/${pkgname#*-*-}/platform:2/")
+source+=(
+ "${pkgname}.zip::https://addons.mozilla.org/firefox/downloads/latest/${pkgname#*-*-}/platform:2/"
+ "version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
+)
+md5sums+=('SKIP')
prepare() {
rm ${pkgname}.zip
@@ -29,6 +33,11 @@ pkgver() {
sparql '<urn:mozilla:install-manifest> em:version ?x' | tr - .
}
+# Retrieve current compatibility information from addons.mozilla.org API.
+query-version() {
+ xmllint version --xpath \
+ "//application[appID='$2']/$1_version/text()"
+}
version-range() {
local emid=$(emid $1)
echo "$1>$(version min $emid)" "$1<$(version max $emid)"
@@ -43,9 +52,7 @@ emid() {
}
version() {
- local version;
- version=$(sparql "[] em:id '$2' ; em:${1}Version ?x" \
- "$srcdir/install.rdf" )
+ local version="$(query-version $1 $2)"
if [[ $version =~ ([[:digit:]]+).\* ]]; then
if [[ $1 = max ]]; then
echo $(( ${BASH_REMATCH[1]} + 1 ))