summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Harvey2019-11-12 20:56:29 +0000
committerChris Harvey2019-11-12 20:56:29 +0000
commit9ececb531203a43f1396da2187e42b4497dafb80 (patch)
tree9cffe99ebd997de9b42a10704c3dbe804d9604b6
downloadaur-9ececb531203a43f1396da2187e42b4497dafb80.tar.gz
Initial commit - 68.2.1
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD30
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4dcab4978d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = thunderbird-ubuntu-bin
+ pkgdesc = Standalone mail and news reader from mozilla.org Ubuntu patches (binary)
+ pkgver = 68.2.1
+ pkgrel = 1
+ url = https://www.thunderbird.net/
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = gtk3
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = nss
+ depends = hunspell
+ depends = sqlite
+ depends = ttf-font
+ depends = icu
+ optdepends = libcanberra: sound support
+ provides = thunderbird
+ provides = thunderbird-ubuntu
+ conflicts = thunderbird
+ conflicts = thunderbird-ubuntu
+ source = http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/pool/main/t/thunderbird/thunderbird_68.2.1+build1-0ubuntu0.19.10.1_amd64.deb
+ sha256sums = dbea72583b831524a0eddfc4770b6ec27d2839ee4a6cb86ab09cca3bd7410474
+
+pkgname = thunderbird-ubuntu-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..858149030675
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Chris Harvey <chris@chrisnharvey.com>
+
+pkgname=thunderbird-ubuntu-bin
+_pkgname=thunderbird
+pkgver=68.2.1
+pkgrel=1
+_ubuntuver="$pkgver+build1-0ubuntu0.19.10.1_amd64"
+pkgdesc="Standalone mail and news reader from mozilla.org Ubuntu patches (binary)"
+arch=("x86_64")
+url="https://www.thunderbird.net/"
+license=(MPL GPL LGPL)
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
+ nss hunspell sqlite ttf-font icu) # libvpx
+optdepends=('libcanberra: sound support')
+provides=('thunderbird' 'thunderbird-ubuntu')
+conflicts=('thunderbird' 'thunderbird-ubuntu')
+
+source=("http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/pool/main/t/thunderbird/thunderbird_$_ubuntuver.deb")
+sha256sums=('dbea72583b831524a0eddfc4770b6ec27d2839ee4a6cb86ab09cca3bd7410474')
+
+prepare() {
+ # Don't extract copyright files, which are included in the licenses package
+ tar -xvf data.tar.xz --exclude=usr/share/doc
+}
+
+package() {
+ cp -r etc "$pkgdir/"
+ cp -r usr "$pkgdir/"
+}
+