summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-02-02 12:29:30 +0600
committerKonstantin Shalygin2016-02-02 12:29:30 +0600
commit9bc04643565f2319ea447604c356274a018e1d44 (patch)
treefc58d326f92ee8984c1f4df1ea9603cc3c0c4361
parentd22c8cf52cb82b1a80e4e8856630eac85a9cb4cf (diff)
downloadaur-9bc04643565f2319ea447604c356274a018e1d44.tar.gz
Fix for makepkg 5.0.0
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33a15f5a321c..3b755e02f45d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 06:27:44 UTC 2016
pkgbase = thunderbird-usebccinstead
pkgdesc = Before the sending occurs it looks for recipients addressed using either TO or CC. When found, it will take action based upon the user-specified options that have been set
pkgver = 3.4.1
- pkgrel = 0
+ pkgrel = 1
url = https://addons.mozilla.org/en-US/thunderbird/addon/use-bcc-instead
arch = any
license = MPL
diff --git a/.gitignore b/.gitignore
index 7c6927b4669a..9807029d71f1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg/*
src/*
*.tar.*
+*.xpi
diff --git a/PKGBUILD b/PKGBUILD
index a2e992b966f1..db0de645dc24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Konstantin Shalygin (k0ste@opentech.ru)
+# Maintainer: Konstantin Shalygin <k0ste@cn.ru>
_bcc='usebccinstead'
_bcc2='use-bcc-instead'
-pkgname=thunderbird-${_bcc}
+pkgname="thunderbird-${_bcc}"
pkgver='3.4.1'
-pkgrel='0'
+pkgrel='1'
pkgdesc='Before the sending occurs it looks for recipients addressed using either TO or CC. When found, it will take action based upon the user-specified options that have been set'
arch=('any')
-url=https://addons.mozilla.org/en-US/thunderbird/addon/${_bcc2}
+url="https://addons.mozilla.org/en-US/thunderbird/addon/${_bcc2}"
license=('MPL')
depends=('thunderbird')
source=("${_bcc}.xpi::https://addons.mozilla.org/thunderbird/downloads/latest/318229/addon-318229-latest.xpi")
@@ -15,7 +15,7 @@ sha256sums=('1fa3f59b822ef0f91af082efcd1ffc26a8b17fa5f85b076ce70154f2ce7c319d')
noextract=(${source[@]%%::*})
package() {
- pushd "$srcdir"
- install -Dm644 "${_bcc}.xpi" "$pkgdir/usr/lib/thunderbird/extensions/{cc138c46-ac77-4397-afc0-6cb6a13b7242}.xpi"
+ pushd "${srcdir}"
+ install -Dm644 "${_bcc}.xpi" "${pkgdir}/usr/lib/thunderbird/extensions/{cc138c46-ac77-4397-afc0-6cb6a13b7242}.xpi"
popd
}