summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Brand2017-04-16 14:07:13 +0200
committerStefan Brand2017-04-16 14:07:13 +0200
commitcdad8876393ef6a109a4cc7127948351e567aba9 (patch)
tree13e07998b2845a9c9254a595b177913ef585dd37
parent5f22bc8b0c288796cd1eb06bfaf3d7f04f13b479 (diff)
downloadaur-cdad8876393ef6a109a4cc7127948351e567aba9.tar.gz
Fix for postinstall patch
-rw-r--r--002_disable_postinstall.patch23
-rw-r--r--PKGBUILD4
2 files changed, 12 insertions, 15 deletions
diff --git a/002_disable_postinstall.patch b/002_disable_postinstall.patch
index 81e5a3c1601e..53320209af41 100644
--- a/002_disable_postinstall.patch
+++ b/002_disable_postinstall.patch
@@ -1,13 +1,10 @@
---- cmake_install.cmake.orig 2017-04-16 13:13:40.562121665 +0200
-+++ cmake_install.cmake 2017-04-16 13:14:02.932269460 +0200
-@@ -104,10 +104,6 @@
- endif()
- endif()
-
--if("${CMAKE_INSTALL_COMPONENT}" STREQUAL "script" OR NOT CMAKE_INSTALL_COMPONENT)
-- include("/home/seiichiro/Misc/AUR/thunderboltd-git/src/thunderboltd/ThunderboltService/Linux/post_install_script.cmake")
--endif()
--
- if(NOT CMAKE_INSTALL_LOCAL_ONLY)
- # Include the install script for each subdirectory.
- include("/home/seiichiro/Misc/AUR/thunderboltd-git/src/thunderboltd/build/gmock/cmake_install.cmake")
+--- ThunderboltService/Linux/CMakeLists.txt.orig 2017-04-16 14:04:49.297485952 +0200
++++ ThunderboltService/Linux/CMakeLists.txt 2017-04-16 14:05:02.064226810 +0200
+@@ -163,7 +163,6 @@
+ install(FILES ${CONFIG_DIR}/thunderbolt.conf DESTINATION ${DBUS_CONFIG_DIR} COMPONENT config)
+ install(FILES ${CONFIG_DIR}/10-thunderbolt.rules DESTINATION ${UDEV_RULES_DIR} COMPONENT config)
+ install(TARGETS thunderboltd DESTINATION ${DAEMON_INSTALL_DIR} COMPONENT binary)
+- install(SCRIPT post_install_script.cmake COMPONENT script)
+ else()
+ message(WARNING
+ "Can't install Thunderbolt daemon because systemd or dbus couldn't be found")
diff --git a/PKGBUILD b/PKGBUILD
index a94973eb57ae..64c2e668aca3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ source=('thunderboltd::git+https://github.com/01org/thunderbolt-software-user-sp
'002_disable_postinstall.patch')
md5sums=('SKIP'
'713ee1db7eea31db2cd5093c615225a3'
- 'eb52425947438ed6f7f334bfe48f5066')
+ 'e4c896b0edf447423b93983c193606e3')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -26,13 +26,13 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
patch -p0 -i "$srcdir/001_fix_sysmacros_include.patch"
+ patch -p0 -i "$srcdir/002_disable_postinstall.patch"
mkdir -p build
}
build() {
cd "$srcdir/${pkgname%-git}/build"
cmake ../ThunderboltService/Linux -DCMAKE_BUILD_TYPE=Release
- patch -p0 -i $srcdir/002_disable_postinstall.patch
make
}