summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradrien10182020-02-19 17:12:36 +0800
committeradrien10182020-02-19 17:12:36 +0800
commit0f4825dc7c39d8afdcef8cb879f0b862474ab3b1 (patch)
treed91ee7eeacf4898e226a528a801196467914c4d1
parente522d391cee3b63b03d678669c5d3a2c64d6f4d3 (diff)
downloadaur-0f4825dc7c39d8afdcef8cb879f0b862474ab3b1.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caf7ec749427..5921363d85aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = thundersvm
makedepends = cuda
makedepends = cmake
makedepends = python-wheel
+ makedepends = python-setuptools
source = https://github.com/Xtra-Computing/thundersvm/archive/v0.3.4.tar.gz
sha256sums = c8b4f7ece312a51ab72ef72e550f7ca3973f5328bc128df64158fe6e3b3b8c0e
diff --git a/PKGBUILD b/PKGBUILD
index bd8cd3913782..8a88d5537d37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Adrien Wu <adrien.sf.wu@gmail.com>
pkgbase=thundersvm
+_pkgbase=thundersvm
pkgname=('thundersvm' 'python-thundersvm')
pkgver=0.3.4
pkgrel=1
pkgdesc="A Fast SVM Library on GPUs and CPUs"
url="https://github.com/Xtra-Computing/thundersvm"
license=('APL')
-makedepends=(cuda cmake python-wheel)
+makedepends=(cuda cmake python-wheel python-setuptools)
arch=('x86_64')
-source=("https://github.com/Xtra-Computing/${pkgbase}/archive/v${pkgver}.tar.gz")
+source=("https://github.com/Xtra-Computing/${_pkgbase}/archive/v${pkgver}.tar.gz")
sha256sums=('c8b4f7ece312a51ab72ef72e550f7ca3973f5328bc128df64158fe6e3b3b8c0e')
build() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir/$_pkgbase-$pkgver"
rm -rf build
mkdir build
cd build
@@ -26,7 +27,7 @@ package_thundersvm() {
provides=(thundersvm)
depends=(cuda)
conflicts=(thundersvm-cpu thundersvm-git)
- cd "$srcdir/$pkgbase-$pkgver/build"
+ cd "$srcdir/$_pkgbase-$pkgver/build"
chrpath -d bin/thundersvm-predict
chrpath -d bin/thundersvm-train
install -Dm755 bin/thundersvm-predict "$pkgdir/usr/bin/thundersvm-predict"
@@ -40,6 +41,6 @@ package_python-thundersvm() {
provides=(python-thundersvm)
depends=(thundersvm)
conflicts=(python-thundersvm-cpu)
- cd "$srcdir/$pkgbase-$pkgver/python"
+ cd "$srcdir/$_pkgbase-$pkgver/python"
BUILD_TAG= python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}