summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2020-05-02 01:48:36 -0400
committerAlexei Colin2020-05-02 01:48:36 -0400
commit8b6af02d92905f34e8493aa0b1e6a54a9cb65b81 (patch)
tree6fb01a0c8ac0b48e08908d7a2278e5e00d7d1151
parentc9afcf3b0580347f154d0e5bbf062e91e31b2863 (diff)
downloadaur-8b6af02d92905f34e8493aa0b1e6a54a9cb65b81.tar.gz
20.2.1.LTS (+ some old changes)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD35
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 392eaccd26f2..bafc8aeb666f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = ti-cgt-arm
pkgdesc = Texas Instruments Code Generation Tools (compiler) for ARM
- pkgver = 19.6.0.STS
+ pkgver = 20.2.1.LTS
pkgrel = 1
url = http://www.ti.com/tool/ARM-CGT
arch = x86_64
license = custom
makedepends = lib32-glibc
+ makedepends = lib32-fakeroot
optdepends = ccstudio
options = !strip
options = libtool
@@ -13,8 +14,8 @@ pkgbase = ti-cgt-arm
options = emptydirs
options = !purge
options = !zipman
- source = http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/19.6.0.STS/ti_cgt_tms470_19.6.0.STS_linux_installer_x86.bin
- sha256sums = 16928b154dfd7735ea469b41d6f409559c976f44fb7f32dc2f306aa91e90ae04
+ source = http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/20.2.1.LTS/ti_cgt_tms470_20.2.1.LTS_linux_installer_x86.bin
+ sha256sums = fda075c64a7a1367c78d6c7c908b15f4de023112f03a4b96291ba9cd03b35808
pkgname = ti-cgt-arm
diff --git a/PKGBUILD b/PKGBUILD
index 3b690b0b4ef0..b2b50936bb00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Alexei Colin <ac at alexeicolin dot com>
pkgname=ti-cgt-arm
-pkgver=19.6.0.STS
+pkgver=20.2.1.LTS
+_manifest_ver=20.2.0.LTS
pkgrel=1
pkgdesc="Texas Instruments Code Generation Tools (compiler) for ARM"
arch=('x86_64')
@@ -9,7 +10,7 @@ url="http://www.ti.com/tool/ARM-CGT"
license=('custom')
# lib32-glibc needed for the installer
-makedepends=('lib32-glibc')
+makedepends=('lib32-glibc' 'lib32-fakeroot')
optdepends=('ccstudio')
@@ -18,34 +19,28 @@ source=("http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${pkgver}/${
options=(!strip libtool staticlibs emptydirs !purge !zipman)
-_ccsdir=ccstudio
-_destdir=opt
-_installdir=installdir
-_installloc=$_ccsdir/ccs/tools/compiler
-_installpath=$_installdir/$_destdir/$_installloc
+_ccsdir=opt/ccstudio
+_installdir=ccs/tools/compiler
prepare() {
cd $srcdir
chmod +x ./${_installer}
}
-build() {
- cd $srcdir
-
- # Calling from build to avoid fakeroot, assuming the same problem exists as
- # for ccstudio installer (see ccstudio/PKGBUILD for details)
- ./${_installer} --mode unattended --prefix $srcdir/$_installpath
-}
-
package() {
+ echo ">>> To save time, you can build uncompressed package:"
+ echo ">>> PKGEXT=.pkg.tar makepkg"
+
+ echo ">>> Running installer..."
+ echo ">>> Errors about acl like below are harmless (please ignore):"
+ echo ">>> dlsym(acl_get_fd): /usr/lib32/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd"
- # Hardlink to avoid time and space overhead
- cp -ral $srcdir/$_installdir/$_destdir $pkgdir/
+ ./${_installer} --mode unattended --prefix $pkgdir/${_ccsdir}/${_installdir}
# Match permissions to ccstudio package (see notes in ccstudio.install)
- find $pkgdir/$_destdir/$_ccsdir -type d -exec chmod 0775 {} \;
+ find $pkgdir/${_ccsdir} -type d -exec chmod 0775 {} \;
- install -D -m0644 $srcdir/${_installpath}/${pkgname}_${pkgver}/ARM_RTS_${pkgver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
+ install -D -m0644 $pkgdir/${_ccsdir}/${_installdir}/${pkgname}_${pkgver}/ARM_RTS_${_manifest_ver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
}
-sha256sums=('16928b154dfd7735ea469b41d6f409559c976f44fb7f32dc2f306aa91e90ae04')
+sha256sums=('fda075c64a7a1367c78d6c7c908b15f4de023112f03a4b96291ba9cd03b35808')