summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2023-09-10 16:09:51 -0400
committerAlexei Colin2023-09-10 16:09:51 -0400
commit11332590d1ab6c208a9d29bf85fb813555cdc2fa (patch)
treef97023d24cda19677207ed0e53130b9d97a2bd80
parent1889cd99c309ece9e26b434cdd9ab8cb9d55dab9 (diff)
downloadaur-ti-cgt-msp430.tar.gz
update to 21.6.1.LTS
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d7ee84fc486..ab5e3f22630d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = ti-cgt-msp430
pkgdesc = Texas Instruments Code Generation Tools (compiler) for MSP430
- pkgver = 20.2.1.LTS
- pkgrel = 2
+ pkgver = 21.6.1.LTS
+ pkgrel = 1
url = https://www.ti.com/tool/MSP-CGT
arch = x86_64
license = custom
- makedepends = lib32-glibc
- makedepends = lib32-fakeroot
conflicts = ccstudio
options = !strip
options = libtool
@@ -14,8 +12,7 @@ pkgbase = ti-cgt-msp430
options = emptydirs
options = !purge
options = !zipman
- source = http://software-dl.ti.com/codegen/esd/cgt_public_sw/MSP430/20.2.1.LTS/ti_cgt_msp430_20.2.1.LTS_linux_installer_x86.bin
- sha256sums = ce03d03441a3bcb2324eff2b0fc1b21c90f79f86a51a4499dbd45b58e0306a64
+ source = https://dr-download.ti.com/software-development/ide-configuration-compiler-or-debugger/MD-p4jWEYpR8n/21.6.1.LTS/ti_cgt_msp430_21.6.1.LTS_linux-x64_installer.bin
+ md5sums = b960da86bfe4d022c1b1c29968223904
pkgname = ti-cgt-msp430
-
diff --git a/PKGBUILD b/PKGBUILD
index 371a946aedc9..449979612ea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Alexei Colin <ac at alexeicolin dot com>
pkgname=ti-cgt-msp430
-pkgver=20.2.1.LTS
-_manifest_ver=20.2.0.LTS
-pkgrel=2
+pkgver=21.6.1.LTS
+pkgrel=1
pkgdesc="Texas Instruments Code Generation Tools (compiler) for MSP430"
arch=('x86_64')
url="https://www.ti.com/tool/MSP-CGT"
license=('custom')
-# lib32-glibc needed for the installer
-makedepends=('lib32-glibc' 'lib32-fakeroot')
#optdepends=('ccstudio')
conflicts=('ccstudio') # current package ships with toolchains
-_installer=ti_cgt_msp430_${pkgver}_linux_installer_x86.bin
-source=("http://software-dl.ti.com/codegen/esd/cgt_public_sw/MSP430/${pkgver}/${_installer}")
+_installer="ti_cgt_msp430_${pkgver}_linux-x64_installer.bin"
+source=("https://dr-download.ti.com/software-development/ide-configuration-compiler-or-debugger/MD-p4jWEYpR8n/${pkgver}/${_installer}")
+md5sums=("b960da86bfe4d022c1b1c29968223904")
options=(!strip libtool staticlibs emptydirs !purge !zipman)
@@ -29,15 +27,11 @@ prepare() {
package() {
echo ">>> Running installer..."
- echo ">>> Errors about acl like below are harmless (please ignore):"
- echo ">>> dlsym(acl_get_fd): /usr/lib32/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd"
./${_installer} --mode unattended --prefix $pkgdir/${_ccsdir}/${_installdir}
# Match permissions to ccstudio package (see notes in ccstudio.install)
find $pkgdir/${_ccsdir} -type d -exec chmod 0775 {} \;
- install -D -m0644 $pkgdir/${_ccsdir}/${_installdir}/${pkgname}_${pkgver}/MSP430_RTS_${_manifest_ver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
+ install -D -m0644 $pkgdir/${_ccsdir}/${_installdir}/${pkgname}_${pkgver}/MSP430_RTS_${pkgver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
}
-
-sha256sums=('ce03d03441a3bcb2324eff2b0fc1b21c90f79f86a51a4499dbd45b58e0306a64')