summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-08-11 14:22:00 -0400
committerredfish2018-08-11 14:22:00 -0400
commit9c2ee48e9371d893486990b668edc62975e9d040 (patch)
treee74957b1d4c43eaff6b24aa5c3636e44d59ef040
parentda8e55ca708a6dcb8d9becba123f7eb3450b95b2 (diff)
downloadaur-9c2ee48e9371d893486990b668edc62975e9d040.tar.gz
update to 18.1.3.LTS
Add suffix to package version, in order to match upstream. Add license. Also, switch to sha256sums.
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD18
3 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eee66a3b106..b0f463ee5cec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Mar 1 11:50:07 UTC 2018
+# Sat Aug 11 18:21:44 UTC 2018
pkgbase = ti-cgt-msp430
pkgdesc = Texas Instruments Code Generation Tools (compiler) for MSP430
- pkgver = 18.1.1
+ pkgver = 18.1.3.LTS
pkgrel = 1
- url = http://software-dl.ti.com/codegen/non-esd/downloads/index.htm
+ url = http://software-dl.ti.com/codegen/non-esd/downloads/index.htm#MSP430
arch = x86_64
license = custom
optdepends = ccstudio
@@ -14,8 +14,8 @@ pkgbase = ti-cgt-msp430
options = emptydirs
options = !purge
options = !zipman
- source = ti_cgt_msp430_18.1.1.LTS_linux_installer_x86.bin::http://software-dl.ti.com/codegen/esd/cgt_public_sw/MSP430/18.1.1.LTS/ti_cgt_msp430_18.1.1.LTS_linux_installer_x86.bin
- md5sums = 2de92040dda2d41bb394aa658c112027
+ source = http://downloads.ti.com/codegen/esd/cgt_public_sw/MSP430/18.1.3.LTS/ti_cgt_msp430_18.1.3.LTS_linux_installer_x86.bin
+ sha256sums = 1ba8c8e9f54d9b5f8e0cde472309cb5c3a249a93aac7e36936bae19d1a9a85ce
pkgname = ti-cgt-msp430
diff --git a/.gitignore b/.gitignore
index 6cf6313d0646..9a86d021a817 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
+pkg/
+src/
+
*.log
.*.swp
.*.swo
diff --git a/PKGBUILD b/PKGBUILD
index abf7a2720bff..de166772031c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Alexei Colin <ac at alexeicolin dot com>
pkgname=ti-cgt-msp430
-pkgver=18.1.1
+pkgver=18.1.3.LTS
pkgrel=1
pkgdesc="Texas Instruments Code Generation Tools (compiler) for MSP430"
arch=('x86_64')
-url="http://software-dl.ti.com/codegen/non-esd/downloads/index.htm"
+url="http://software-dl.ti.com/codegen/non-esd/downloads/index.htm#MSP430"
#url="http://www.ti.com/tools-software/compilers/download.html"
license=('custom')
optdepends=('ccstudio')
-_fullver=${pkgver}.LTS
-_installer=ti_cgt_msp430_${_fullver}_linux_installer_x86.bin
-source=("${_installer}::http://software-dl.ti.com/codegen/esd/cgt_public_sw/MSP430/${_fullver}/${_installer}")
+_installer=ti_cgt_msp430_${pkgver}_linux_installer_x86.bin
+source=("http://downloads.ti.com/codegen/esd/cgt_public_sw/MSP430/${pkgver}/${_installer}")
-md5sums=('2de92040dda2d41bb394aa658c112027')
options=(!strip libtool staticlibs emptydirs !purge !zipman)
+_ccsver=8
_ccsdir=ccstudio
_destdir=opt
_installdir=installdir
-_installloc=$_ccsdir/ccsv7/tools/compiler
+_installloc=$_ccsdir/ccsv$_ccsver/tools/compiler
_installpath=$_installdir/$_destdir/$_installloc
_tooldir=${pkgname}_${pkgver}
@@ -46,4 +45,9 @@ package() {
# Match permissions to ccstudio package (see notes in ccstudio.install)
find $pkgdir/$_destdir/$_ccsdir -type d -exec chmod 0775 {} \;
+
+ # Version in filename is out of date upstream
+ install -D -m0644 $srcdir/${_installpath}/${pkgname}_${pkgver}/MSP430_RTS_18.1.0.LTS.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
}
+
+sha256sums=('1ba8c8e9f54d9b5f8e0cde472309cb5c3a249a93aac7e36936bae19d1a9a85ce')