summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2019-10-13 13:52:30 -0400
committerAlexei Colin2019-10-13 13:52:30 -0400
commite723fb7a5e57a96af3d25f8a8f1f5d663ee8aa46 (patch)
tree23e227be9e2b7d0722e75bfb5a8464c6c1e3f342
parent1766406d8c24da71ab059afbfcb22c97645679e5 (diff)
downloadaur-e723fb7a5e57a96af3d25f8a8f1f5d663ee8aa46.tar.gz
install directly into pkgdir
The fakeroot problem has been resolved (except for a harmless warning).
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 793c5be5ce43..ce2e1304829c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = ti-cgt-msp430
arch = x86_64
license = custom
makedepends = lib32-glibc
+ makedepends = lib32-fakeroot
optdepends = ccstudio
options = !strip
options = libtool
diff --git a/.gitignore b/.gitignore
index 9a86d021a817..151d1228a110 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,5 @@ src/
.*.swp
.*.swo
*.tar.xz
+*.tar
*.bin
diff --git a/PKGBUILD b/PKGBUILD
index d68a09986d3d..0a67caaeae59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,45 +9,37 @@ url="https://www.ti.com/tool/MSP-CGT"
license=('custom')
# lib32-glibc needed for the installer
-makedepends=('lib32-glibc')
+makedepends=('lib32-glibc' 'lib32-fakeroot')
optdepends=('ccstudio')
_installer=ti_cgt_msp430_${pkgver}_linux_installer_x86.bin
source=("http://software-dl.ti.com/codegen/esd/cgt_public_sw/MSP430/${pkgver}/${_installer}")
-
options=(!strip libtool staticlibs emptydirs !purge !zipman)
-_ccsdir=ccstudio
-_destdir=opt
-_installdir=installdir
-_installloc=$_ccsdir/ccs/tools/compiler
-_installpath=$_installdir/$_destdir/$_installloc
-_tooldir=${pkgname}_${pkgver}
+_ccsdir=opt/ccstudio
+_installdir=ccs/tools/compiler
prepare() {
cd $srcdir
chmod +x ./${_installer}
}
-build() {
- cd $srcdir
-
- # Calling from build to avoid fakeroot, assuming the same problem exists as
- # for ccstudio installer (see ccstudio/PKGBUILD for details)
- ./${_installer} --mode unattended --prefix $srcdir/$_installpath
-}
-
package() {
+ echo ">>> To save time, you can build uncompressed package:"
+ echo ">>> PKGEXT=.tar makepkg"
+
+ echo ">>> Running installer..."
+ echo ">>> Errors about acl like below are harmless (please ignore):"
+ echo ">>> dlsym(acl_get_fd): /usr/lib32/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd"
- # Hardlink to avoid time and space overhead
- cp -ral $srcdir/$_installdir/$_destdir $pkgdir/
+ ./${_installer} --mode unattended --prefix $pkgdir/${_ccsdir}/${_installdir}
# Match permissions to ccstudio package (see notes in ccstudio.install)
- find $pkgdir/$_destdir/$_ccsdir -type d -exec chmod 0775 {} \;
+ find $pkgdir/${_ccsdir} -type d -exec chmod 0775 {} \;
- install -D -m0644 $srcdir/${_installpath}/${pkgname}_${pkgver}/MSP430_RTS_${pkgver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
+ install -D -m0644 $pkgdir/${_ccsdir}/${_installdir}/${pkgname}_${pkgver}/MSP430_RTS_${pkgver}_manifest.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
}
sha256sums=('842eb32a5104b9b1bc91e00d3a3d92d25829a7998ea83db4a1cdf8052685622c')