summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2023-09-10 16:34:07 -0400
committerAlexei Colin2023-09-10 16:34:07 -0400
commit23ea149908e42cf5cdac4094c06ba705c60bdcbb (patch)
treede236562c2a125692f3d22852e90e267a39f76d7
parent99d3e71c95e0460fa5b16b6b3398074a4e587736 (diff)
downloadaur-23ea149908e42cf5cdac4094c06ba705c60bdcbb.tar.gz
update to 3.80.14.01
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5bcf38c0a1a..b4da6522ecfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ti-msp430ware
pkgdesc = Texas Instruments MSP430Ware library for MSP430 microcontrollers
- pkgver = 3.80.13.03
+ pkgver = 3.80.14.01
pkgrel = 1
url = https://www.ti.com/tool/MSPWARE
arch = x86_64
@@ -13,8 +13,7 @@ pkgbase = ti-msp430ware
options = emptydirs
options = !purge
options = !zipman
- source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSP430Ware/latest/exports/MSP430Ware_3_80_13_03_setup.run
- sha256sums = f92fe8e32f28188bcf797412c669632bc3b38954199ef2edf745383859f80c90
+ source = https://dr-download.ti.com/secure/software-development/software-development-kit-sdk/MD-L2UkJRAuzb/3.80.14.01/MSP430Ware_3_80_14_01_setup.run?__gda__=
+ md5sums = 8b2030e98e62e1cf37871015cbc68617
pkgname = ti-msp430ware
-
diff --git a/PKGBUILD b/PKGBUILD
index 0a88f02616a7..fda38652e82d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
# Maintainer: Alexei Colin <ac at alexeicolin dot com>
pkgname=ti-msp430ware
-pkgver=3.80.13.03
-_upver=3_80_13_03
+pkgver=3.80.14.01
pkgrel=1
pkgdesc="Texas Instruments MSP430Ware library for MSP430 microcontrollers"
arch=('x86_64')
@@ -13,9 +12,18 @@ license=('custom')
# lib32-glibc needed for the installer
makedepends=('lib32-glibc' 'lib32-fakeroot')
-_name=MSP430Ware_${_upver}
+_name=MSP430Ware_${pkgver//./_}
_installer=${_name}_setup.run
-source=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSP430Ware/latest/exports/${_installer}")
+
+# To download the file, you need to manually navigate to the website, create an
+# account, and accept the license for this software. Otherwise, this pkgbuild
+# would download an HTML page that will fail the checksum check. Once you accepted
+# the license, then you can either download the file manually and place it in
+# the folder with this PKGBUILD, or you could paste the identifier that appears
+# in the final download URL from TI website into this variable:
+_gda=
+source=("https://dr-download.ti.com/secure/software-development/software-development-kit-sdk/MD-L2UkJRAuzb/${pkgver}/${_installer}?__gda__=${_gda}")
+md5sums=("8b2030e98e62e1cf37871015cbc68617") # TI website lists the MD5 sum specifically
options=(!strip libtool staticlibs emptydirs !purge !zipman)
@@ -27,12 +35,7 @@ prepare() {
}
package() {
- echo ">>> To save time, you can build uncompressed package:"
- echo ">>> PKGEXT=.pkg.tar makepkg"
-
echo ">>> Running installer..."
- echo ">>> Errors about acl like below are harmless (please ignore):"
- echo ">>> dlsym(acl_get_fd): /usr/lib32/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd"
./${_installer} --mode unattended --prefix $pkgdir/${_installdir}
mv $pkgdir/${_installdir}/{install_logs,${_name}}/${_name}_install.log
@@ -40,5 +43,3 @@ package() {
install -D -m0644 $pkgdir/${_installdir}/${_name}/license.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
-
-sha256sums=('f92fe8e32f28188bcf797412c669632bc3b38954199ef2edf745383859f80c90')