summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2017-06-30 19:29:23 +0200
committerNarrat2017-06-30 19:29:23 +0200
commit365b64be2607d190c9486dac9e7f8c8747592f03 (patch)
tree063560b868dd04d9af7f660e21937e9fa51e1c82
parent6ea17bf4e8fe20fbbd8773c087386773c9ad0235 (diff)
downloadaur-365b64be2607d190c9486dac9e7f8c8747592f03.tar.gz
Tibia: Add FREETYPE_PROPERTIES to start-tibia.sh
Suggestion by luan
-rw-r--r--.SRCINFO4
-rw-r--r--02_freetype.patch10
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b624e6ea7ba8..834a4da3781f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tibia
pkgdesc = fast-paced free massively multiplayer online role-playing game
pkgver = 11.32.5246
- pkgrel = 3
+ pkgrel = 4
url = http://www.tibia.com
arch = x86_64
license = custom
@@ -18,9 +18,11 @@ pkgbase = tibia
source = tibia-11.32.5246.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz
source = tibia-agreement.php::http://www.tibia.com/support/agreement.php
source = 01_openssl102.patch
+ source = 02_freetype.patch
sha256sums = 907421de4de759f424c00bd8c1fa836568ff2fc80b9a0ca792bef1876747cdae
sha256sums = 965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5
sha256sums = 32eed70b7460908498e111e181ae5c2080ef0027cb5dc6fbea9e621b96f8ed0c
+ sha256sums = d989b6823c6dd1aa510f4b76df1a62579966ffdcd4a0ff7ac51b3d547c8930c1
pkgname = tibia
diff --git a/02_freetype.patch b/02_freetype.patch
new file mode 100644
index 000000000000..a8bea9ce668c
--- /dev/null
+++ b/02_freetype.patch
@@ -0,0 +1,10 @@
+--- tibia-11.32.5246/start-tibia.sh
++++ tibia-11.32.5246/start-tibia.sh
+@@ -6,5 +6,6 @@
+ SCRIPT=$(readlink -f "$0")
+ PATH=$(dirname "$SCRIPT")
+ BIN_PATH="$PATH/bin"
++export FREETYPE_PROPERTIES="truetype:interpreter-version=38"
+
+ LD_LIBRARY_PATH="$BIN_PATH" exec "$BIN_PATH/client"
+
diff --git a/PKGBUILD b/PKGBUILD
index 3352f17383e1..70a242675bf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=tibia
pkgver=11.32.5246
-pkgrel=3
+pkgrel=4
pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
url="http://www.tibia.com"
@@ -12,11 +12,13 @@ makedepends=('gendesk' 'python-html2text')
source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
"${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php"
- "01_openssl102.patch")
+ "01_openssl102.patch"
+ "02_freetype.patch")
sha256sums=('907421de4de759f424c00bd8c1fa836568ff2fc80b9a0ca792bef1876747cdae'
'965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5'
- '32eed70b7460908498e111e181ae5c2080ef0027cb5dc6fbea9e621b96f8ed0c')
+ '32eed70b7460908498e111e181ae5c2080ef0027cb5dc6fbea9e621b96f8ed0c'
+ 'd989b6823c6dd1aa510f4b76df1a62579966ffdcd4a0ff7ac51b3d547c8930c1')
prepare() {
gendesk -f -n
@@ -24,6 +26,8 @@ prepare() {
# Tibia relies on openssl 1.0.x
patch -Np0 -i "${srcdir}/01_openssl102.patch"
+ # Tibia relies on specific freetype version
+ patch -Np0 -i "${srcdir}/02_freetype.patch"
}
package() {