summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2017-06-30 19:20:18 +0200
committerNarrat2017-06-30 19:20:18 +0200
commit6ea17bf4e8fe20fbbd8773c087386773c9ad0235 (patch)
tree80467354c93ba874383331848de9ec57430b205f
parent3e9874b2de730c74fedf29f1179e160e6be9ef93 (diff)
downloadaur-6ea17bf4e8fe20fbbd8773c087386773c9ad0235.tar.gz
Tibia: add openssl-1.0 path
Tibia is using openssl-1.0 for SSL stuff, which caused problems and manual intervention. Thanks to luan for the solution
-rw-r--r--.SRCINFO5
-rw-r--r--01_openssl102.patch9
-rw-r--r--PKGBUILD13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c55118b4d29..b624e6ea7ba8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tibia
pkgdesc = fast-paced free massively multiplayer online role-playing game
pkgver = 11.32.5246
- pkgrel = 2
+ pkgrel = 3
url = http://www.tibia.com
arch = x86_64
license = custom
@@ -11,13 +11,16 @@ pkgbase = tibia
depends = libgl
depends = libice
depends = libxext
+ depends = openssl-1.0
depends = pcre
depends = qt5-base
depends = qt5-declarative
source = tibia-11.32.5246.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz
source = tibia-agreement.php::http://www.tibia.com/support/agreement.php
+ source = 01_openssl102.patch
sha256sums = 907421de4de759f424c00bd8c1fa836568ff2fc80b9a0ca792bef1876747cdae
sha256sums = 965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5
+ sha256sums = 32eed70b7460908498e111e181ae5c2080ef0027cb5dc6fbea9e621b96f8ed0c
pkgname = tibia
diff --git a/01_openssl102.patch b/01_openssl102.patch
new file mode 100644
index 000000000000..f22d1b55f64e
--- /dev/null
+++ b/01_openssl102.patch
@@ -0,0 +1,9 @@
+--- tibia-11.32.5246/start-tibia.sh
++++ tibia-11.32.5246/start-tibia.sh
+@@ -7,4 +7,4 @@
+ PATH=$(dirname "$SCRIPT")
+ BIN_PATH="$PATH/bin"
+
+-LD_LIBRARY_PATH="$BIN_PATH" exec "$BIN_PATH/client"
++LD_LIBRARY_PATH="$BIN_PATH:/usr/lib/openssl-1.0/" exec "$BIN_PATH/client"
+
diff --git a/PKGBUILD b/PKGBUILD
index ee3ab038dd5b..3352f17383e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,28 @@
pkgname=tibia
pkgver=11.32.5246
-pkgrel=2
+pkgrel=3
pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
url="http://www.tibia.com"
license=('custom')
-depends=('glu' 'libgl' 'libice' 'libxext' 'pcre' 'qt5-base' 'qt5-declarative')
+depends=('glu' 'libgl' 'libice' 'libxext' 'openssl-1.0' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
- "${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php")
+ "${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php"
+ "01_openssl102.patch")
sha256sums=('907421de4de759f424c00bd8c1fa836568ff2fc80b9a0ca792bef1876747cdae'
- '965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5')
+ '965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5'
+ '32eed70b7460908498e111e181ae5c2080ef0027cb5dc6fbea9e621b96f8ed0c')
prepare() {
gendesk -f -n
html2text "${pkgname}-agreement.php" > LICENSE
+
+ # Tibia relies on openssl 1.0.x
+ patch -Np0 -i "${srcdir}/01_openssl102.patch"
}
package() {