summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2017-02-12 19:49:48 +0100
committerNarrat2017-02-12 19:49:48 +0100
commit8b863bf0826d9f3332fc95499495c867a20a3693 (patch)
treeb1ca4f981e5e5ca5feffa8076787e58eabcbd820
parent44f93db9cc2c1a5cf19c5229e96f1cd8df2af9cc (diff)
downloadaur-8b863bf0826d9f3332fc95499495c867a20a3693.tar.gz
tibia: Update to build 11.10.4445 and some cleanup
Give the agreement file a name, which can be associated with a package. This is for people using a common SRCDEST for alle Source packages. Problem which needs to be resolved is for people which use BUILDDIR. gendesk seems to hardcode the path for the PKGBUILD, which may not be the upper directory
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
-rw-r--r--tibia-starter.patch4
3 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e636c96ea9b..d239ac3d1d60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Jan 20 16:55:24 UTC 2017
pkgbase = tibia
pkgdesc = A fast-paced free massively multiplayer online role-playing game.
- pkgver = 11.04.4347
+ pkgver = 11.10.4445
pkgrel = 1
url = http://www.tibia.com
arch = x86_64
@@ -16,12 +14,12 @@ pkgbase = tibia
depends = pcre
depends = qt5-base
depends = qt5-declarative
- source = tibia-11.04.4347.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz
- source = http://www.tibia.com/support/agreement.php
+ source = tibia-11.10.4445.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz
+ source = tibia-agreement.php::http://www.tibia.com/support/agreement.php
source = tibia-starter.patch
- sha256sums = 6e2ef99bc264b9feff47db103d82ae1f9d6648d66ca1689b73a6d1fd58160f2f
- sha256sums = fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34
- sha256sums = 345547cf4fd388758d7d28638135f1861f33c1712bac3dc5870a1423b3d13f99
+ sha256sums = 62f4c59c8371e6b64c75b938092a3d59faa81a8f4a3652afcbbd32fde9b61d67
+ sha256sums = f3913f69f93254c6b35e75d95fb505b1cefa654bd1713bf57b457a4c767e16c0
+ sha256sums = 123f9dc3d7ce4638edf6581ed9540317a318d1eadc36b96d3b348e0cf29131b9
pkgname = tibia
diff --git a/PKGBUILD b/PKGBUILD
index 4c2238d5a646..2156c23a45a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ricardo Cabral <ricardo.arturo.cabral@gmail.com>
pkgname=tibia
-pkgver=11.04.4347
+pkgver=11.10.4445
pkgrel=1
pkgdesc="A fast-paced free massively multiplayer online role-playing game."
arch=('x86_64')
@@ -11,16 +11,16 @@ depends=('glu' 'libgl' 'libice' 'libxext' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
- 'http://www.tibia.com/support/agreement.php'
+ "${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php"
"tibia-starter.patch")
-sha256sums=('6e2ef99bc264b9feff47db103d82ae1f9d6648d66ca1689b73a6d1fd58160f2f'
- 'fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34'
- '345547cf4fd388758d7d28638135f1861f33c1712bac3dc5870a1423b3d13f99')
+sha256sums=('62f4c59c8371e6b64c75b938092a3d59faa81a8f4a3652afcbbd32fde9b61d67'
+ 'f3913f69f93254c6b35e75d95fb505b1cefa654bd1713bf57b457a4c767e16c0'
+ '123f9dc3d7ce4638edf6581ed9540317a318d1eadc36b96d3b348e0cf29131b9')
prepare() {
gendesk -f -n
- html2text agreement.php > LICENSE
+ html2text "${pkgname}-agreement.php" > LICENSE
# Adjust start-tibia.sh
patch -Np1 -i "tibia-starter.patch"
@@ -39,4 +39,3 @@ package() {
mkdir -p "${pkgdir}/usr/bin"
install -Dm755 ${pkgname}-${pkgver}/start-tibia.sh "${pkgdir}/usr/bin/tibia"
}
-
diff --git a/tibia-starter.patch b/tibia-starter.patch
index b2883fba9182..546e12569770 100644
--- a/tibia-starter.patch
+++ b/tibia-starter.patch
@@ -1,5 +1,5 @@
---- a/tibia-11.04.4347/start-tibia.sh
-+++ b/tibia-11.04.4347/start-tibia.sh
+--- a/tibia-11.10.4445/start-tibia.sh
++++ b/tibia-11.10.4445/start-tibia.sh
@@ -3,8 +3,6 @@
# Adapts library load path to include Qt libraries found in the root folder of the client's binary file.
# client shouldn't be called directly to prevent needed libraries not being found.