summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Arturo Cabral2015-11-09 03:40:29 -0400
committerRicardo Arturo Cabral2015-11-09 03:40:29 -0400
commit9566b1faceea7e43415e12f917867c62d1c27d6b (patch)
tree26885c8894f06e0ac0816942facbd8a1af937756
downloadaur-9566b1faceea7e43415e12f917867c62d1c27d6b.tar.gz
First commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--tibia.install9
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02435fa90146
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tibia
+ pkgdesc = A fast-paced free massively multiplayer online role-playing game.
+ pkgver = 1082
+ pkgrel = 1
+ url = http://www.tibia.com
+ install = tibia.install
+ arch = x86_64
+ license = custom
+ makedepends = python-html2text
+ depends = lib32-glu
+ depends = lib32-mesa
+ provides = tibia
+ source = http://static.tibia.com/download/tibia1082.tgz
+ source = http://www.tibia.com/support/agreement.php
+ source = tibia.install
+ sha256sums = f5016b13f51dd1bc99251acc56869a3064ebcb137b793d81e290e57e29098953
+ sha256sums = fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34
+ sha256sums = b4fad80c71133c3209e435d904024261e3a331faaa6a9fcb8cbe99f1ede0c454
+
+pkgname = tibia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edcc103c3290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Ricardo Cabral <ricardo.arturo.cabral@gmail.com>
+_name="Tibia"
+pkgname=tibia
+pkgver=1082
+pkgrel=1
+pkgdesc="A fast-paced free massively multiplayer online role-playing game."
+arch=('x86_64')
+url="http://www.tibia.com"
+license=('custom')
+depends=('lib32-glu' 'lib32-mesa')
+makedepends=('python-html2text')
+provides=('tibia')
+install=${pkgname}.install
+
+source=("http://static.tibia.com/download/tibia${pkgver}.tgz"
+ 'http://www.tibia.com/support/agreement.php' 'tibia.install')
+
+sha256sums=('f5016b13f51dd1bc99251acc56869a3064ebcb137b793d81e290e57e29098953'
+ 'fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34'
+ 'b4fad80c71133c3209e435d904024261e3a331faaa6a9fcb8cbe99f1ede0c454')
+
+prepare() {
+ gendesk -f -n
+}
+
+build() {
+ cd "$srcdir"
+ tar -xf tibia${pkgver}.tgz
+ html2text agreement.php > LICENSE
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "${pkgdir}/opt/Tibia"
+ cp -drv --no-preserve=ownership ./Tibia/ "${pkgdir}/opt/"
+ install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 Tibia/Tibia.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/tibia.install b/tibia.install
new file mode 100644
index 000000000000..59ccf61d1b9e
--- /dev/null
+++ b/tibia.install
@@ -0,0 +1,9 @@
+post_install() {
+ mkdir -p /usr/bin
+ echo -e "#!/bin/sh\ncd \"/opt/Tibia\"\n./Tibia" > /usr/bin/tibia
+ chmod 0755 "/usr/bin/tibia"
+}
+
+post_remove() {
+ rm /usr/bin/tibia
+}