summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Arturo Cabral2016-09-18 20:50:27 -0400
committerRicardo Arturo Cabral2016-09-18 20:50:27 -0400
commitd747c05e8201a7967393582729e75137c20781d1 (patch)
treeb574924bedff0ada40327d337e39523aac6e087a
parent3c37b0a690adea8374dce803457f7fe07a9a6dea (diff)
downloadaur-d747c05e8201a7967393582729e75137c20781d1.tar.gz
Merging patch from TrialnError (2016-07-25)
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
-rw-r--r--tibia.install9
-rwxr-xr-xtibia.sh4
5 files changed, 22 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af893790b7f2..c7798c7f089e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = tibia
pkgdesc = A fast-paced free massively multiplayer online role-playing game.
pkgver = 1096
- pkgrel = 1
+ pkgrel = 2
url = http://www.tibia.com
- install = tibia.install
+ arch = i686
arch = x86_64
license = custom
- makedepends = python-html2text
makedepends = gendesk
- depends = lib32-glu
- depends = lib32-mesa
- provides = tibia
+ makedepends = python-html2text
source = http://static.tibia.com/download/tibia1096.tgz
source = http://www.tibia.com/support/agreement.php
- source = tibia.install
+ source = tibia.sh
sha256sums = 11bec465da38ae8e6d4d773c54142fa38b6f99207b3a9ce118917e31b32a6488
sha256sums = fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34
- sha256sums = b4fad80c71133c3209e435d904024261e3a331faaa6a9fcb8cbe99f1ede0c454
+ sha256sums = 472f7516fe56b5a6270f0bda0069e59559cf6cbc0d9079a6607842a5ee1d1a7b
+ depends_i686 = glu
+ depends_i686 = mesa
+ depends_x86_64 = lib32-glu
+ depends_x86_64 = lib32-mesa
pkgname = tibia
diff --git a/.gitignore b/.gitignore
index f9f3f69c05ef..4391da7c8914 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg/
src/
agreement.php
tibia*
+!tibia.sh
diff --git a/PKGBUILD b/PKGBUILD
index 30cc22f9d775..e5db7638e122 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name="Tibia"
pkgname=tibia
pkgver=1096
-pkgrel=1
+pkgrel=2
pkgdesc="A fast-paced free massively multiplayer online role-playing game."
arch=('i686' 'x86_64')
url="http://www.tibia.com"
@@ -10,31 +10,28 @@ license=('custom')
depends_i686=('glu' 'mesa')
depends_x86_64=('lib32-glu' 'lib32-mesa')
makedepends=('gendesk' 'python-html2text')
-provides=('tibia')
-install=${pkgname}.install
source=("http://static.tibia.com/download/tibia${pkgver}.tgz"
- 'http://www.tibia.com/support/agreement.php')
+ 'http://www.tibia.com/support/agreement.php'
+ "tibia.sh")
sha256sums=('11bec465da38ae8e6d4d773c54142fa38b6f99207b3a9ce118917e31b32a6488'
- 'fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34')
+ 'fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34'
+ '472f7516fe56b5a6270f0bda0069e59559cf6cbc0d9079a6607842a5ee1d1a7b')
prepare() {
gendesk -f -n
-}
-
-build() {
- cd "$srcdir"
- tar -xf tibia${pkgver}.tgz
html2text agreement.php > LICENSE
}
package() {
- cd "$srcdir"
mkdir -p "${pkgdir}/opt/Tibia"
cp -drv --no-preserve=ownership ./Tibia/ "${pkgdir}/opt/"
install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 Tibia/Tibia.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm755 tibia.sh "${pkgdir}/usr/bin/tibia"
}
diff --git a/tibia.install b/tibia.install
deleted file mode 100644
index 59ccf61d1b9e..000000000000
--- a/tibia.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- mkdir -p /usr/bin
- echo -e "#!/bin/sh\ncd \"/opt/Tibia\"\n./Tibia" > /usr/bin/tibia
- chmod 0755 "/usr/bin/tibia"
-}
-
-post_remove() {
- rm /usr/bin/tibia
-}
diff --git a/tibia.sh b/tibia.sh
new file mode 100755
index 000000000000..0143bb9ae2f0
--- /dev/null
+++ b/tibia.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd "/opt/Tibia"
+./Tibia