summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaryJaneInChain2020-06-09 12:05:53 +0800
committerMaryJaneInChain2020-06-09 12:05:53 +0800
commit9769f0384c557a92f24e15e4dcdd97b28ee2ffec (patch)
tree7443fe1c0ae374aba409d2780a4db55024754948
parentc7643007ae41c1da66ab8c70fe3206814bab702b (diff)
downloadaur-9769f0384c557a92f24e15e4dcdd97b28ee2ffec.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fc6dd5d956b..6e97416117b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = tic-80-git
pkgdesc = TIC-80 tiny computer emulator
- pkgver = r1039.de2dacd
+ pkgver = r1103.5b06d67
pkgrel = 1
url = https://tic.computer/
- arch = i686
- arch = x86_64
+ arch = any
license = MIT
makedepends = git
makedepends = cmake
@@ -12,9 +11,8 @@ pkgbase = tic-80-git
depends = glu
depends = freeglut>=3.0.0
depends = libglvnd
+ provides = tic-80
source = git+https://github.com/nesbox/TIC-80.git
- source = git+https://github.com/nesbox/3rd-party.git
- sha256sums = SKIP
sha256sums = SKIP
pkgname = tic-80-git
diff --git a/PKGBUILD b/PKGBUILD
index 5fd681011188..4c0f4b375534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: MaryJaneInChain <maryjaneinchain@gmail.com>
pkgname=tic-80-git
-pkgver=r1039.de2dacd
+pkgver=r1103.5b06d67
pkgrel=1
pkgdesc='TIC-80 tiny computer emulator'
-arch=('i686' 'x86_64')
+arch=('any')
url="https://tic.computer/"
license=('MIT')
depends=('gtk3' 'glu' 'freeglut>=3.0.0' 'libglvnd')
makedepends=('git' 'cmake')
+provides=(tic-80)
_gitname=TIC-80
-source=("git+https://github.com/nesbox/TIC-80.git"
- "git+https://github.com/nesbox/3rd-party.git")
-sha256sums=('SKIP' 'SKIP')
+source=("git+https://github.com/nesbox/TIC-80.git")
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -35,5 +35,9 @@ build() {
package() {
cd "$srcdir/$_gitname/build"
install -Dm755 bin/tic80 "${pkgdir}/usr/bin/tic80"
+ install -Dm755 bin/tic80-sokol "${pkgdir}/usr/bin/tic80-sokol"
+ install -Dm755 bin/player-sdl "${pkgdir}/usr/bin/player-sdl"
+ install -Dm755 bin/player-sokol "${pkgdir}/usr/bin/player-sokol"
+ install -Dm755 bin/bin2txt "${pkgdir}/usr/bin/bin2txt"
}