summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten van Gompel2015-06-21 12:51:38 +0200
committerMaarten van Gompel2015-06-21 12:51:38 +0200
commitb516a425f35db0bca5b3765ec79f575fe6d0179c (patch)
treee2f6340967fb029e87d4a61a32bd97a8581a138e
downloadaur-b516a425f35db0bca5b3765ec79f575fe6d0179c.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63890a286af4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ticcutils-git
+ pkgdesc = Common library with functions for tools developed at Tilburg Centre for Cognition and Communication
+ pkgver = 161
+ pkgrel = 2
+ url = http://ilk.uvt.nl/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libtool
+ makedepends = autoconf
+ depends = gcc-libs
+ depends = libxml2
+ depends = bzip2
+ depends = libtar
+ depends = boost
+ depends = zlib
+ provides = ticcutils
+ conflicts = ticcutils
+ options = !libtool
+ source = git://github.com/proycon/ticcutils.git
+ md5sums = SKIP
+
+pkgname = ticcutils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70836b3a9d20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Maarten van Gompel <proycon at anaproy.nl>
+
+_pkgname=ticcutils
+pkgname=ticcutils-git
+pkgver=161
+pkgrel=2
+pkgdesc="Common library with functions for tools developed at Tilburg Centre for Cognition and Communication"
+arch=('i686' 'x86_64')
+url="http://ilk.uvt.nl/"
+license=('GPL')
+depends=('gcc-libs' 'libxml2' 'bzip2' 'libtar' 'boost' 'zlib')
+provides=('ticcutils')
+conflicts=('ticcutils')
+makedepends=('libtool' 'autoconf')
+options=(!libtool)
+source=("git://github.com/proycon/ticcutils.git")
+_gitname=("ticcutils")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git rev-list --count HEAD
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ bash bootstrap.sh || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR=$pkgdir install
+}
+