aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-05-18 11:59:27 -0400
committerAntony Kellermann2018-05-18 11:59:27 -0400
commit123e79e1ec3307350d04a9658b752e445dff5e03 (patch)
tree800070aeb8277561fef818b7ea6c9abff5673339
parenta187d54d40131e86b91a2a534e7e3cd53e00ebd1 (diff)
downloadaur-123e79e1ec3307350d04a9658b752e445dff5e03.tar.gz
Added documentation for cmp and new version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md13
-rw-r--r--tick.17
4 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d63455f5e86..9c23e3f39fda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tick
pkgdesc = Command line stock and cryptocurrency portfolio tracker.
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/aokellermann/tick
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f301c09aab4e..fef3a6b116b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antony Kellermann <aokellermann@gmail.com>
pkgname=tick
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="Command line stock and cryptocurrency portfolio tracker."
arch=('x86_64')
diff --git a/README.md b/README.md
index 6b88196fa96e..f98d09131816 100644
--- a/README.md
+++ b/README.md
@@ -70,7 +70,18 @@ API constraints. You may press the UP arrow key to zoom in, the DOWN arrow
key to zoom out, the LEFT arrow to pan left, the RIGHT arrow to pan right,
or the letter "q" to quit.
```bash
-$ tick graph tsla
+$ tick graph [symbol]
+```
+
+The cmp command has the same functionality as graph, but is intended for
+comparing two securities. The command takes two symbols as arguments.
+Both graphs will be displayed. To com
+```bash
+$ tick cmp [symbol] [symbol]
+```
+To compare the graphs of Tesla and Ford, run
+```bash
+$ tick cmp tsla f
```
To get the top three news articles on a specific stock or cryptocurrency,
diff --git a/tick.1 b/tick.1
index 131747e1a6a4..41d5c27b517e 100644
--- a/tick.1
+++ b/tick.1
@@ -1,4 +1,4 @@
-.TH TICK "1" "May 2018" "Tick 2.0.0" "User Commands"
+.TH TICK "1" "May 2018" "Tick 2.1.0" "User Commands"
.SH NAME
Tick - Command line stock and cryptocurrency portfolio tracker.
@@ -51,6 +51,11 @@ You may press the UP arrow key to zoom in, the DOWN arrow key to zoom out, the L
to pan right, or the letter "q" to quit.
.TP
+[cmp] [symbol] [symbol]
+Same functionality to "graph", but is intended for comparing two securities. The command takes two symbols as
+arguments. Both graphs will be displayed.
+
+.TP
[news] [symbol]
Prints information on the top three news articles in the past 14 days. The article titles, sources, authors, dates, and URLs
will be displayed. If you would like to use a space in your search, you must either use an underscore instead of the space or wrap