aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-03-11 18:43:44 -0400
committerAntony Kellermann2018-03-11 18:43:44 -0400
commit66282968a7ae2af1abea77813df6c9af8073fe41 (patch)
tree6c84a96a2a03664bc91a1551f8bf3671fc1bbcec
parent14f8cee31de87bfd70d00b6605d58fdeeaca9236 (diff)
downloadaur-66282968a7ae2af1abea77813df6c9af8073fe41.tar.gz
Small updates to Makefile, PKGBUILD, README
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD5
-rw-r--r--README.md3
3 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 924c6176cff3..7d638b50011a 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@ CFLAGS = -g -Wall --std=c99 -D_FORTIFY_SOURCE=2 -O2 \
-Wbad-function-cast -Wstrict-overflow=5 -Wstrict-prototypes -Winline \
-Wundef -Wnested-externs -Wcast-qual -Wunreachable-code \
-ggdb3 -fno-omit-frame-pointer -ffloat-store -fno-common -fstrict-aliasing
-OBJECTS = main.o api.o portfolio.o rc4.o string-tick.o
+OBJECTS = main.o api.o portfolio.o rc4.o string-tick.o graph.o
LIBS = -lcurl -ljson-c -lm -lncurses
BIN = tick
DESTDIR = /usr
diff --git a/PKGBUILD b/PKGBUILD
index 9180c47993b4..e6f79211a60e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,6 @@ build() {
}
package() {
- install -Dm755 "$srcdir/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$srcdir/$pkgname/$pkgname.1.gz" "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
+ cd "$srcdir/$pkgname"
+ make DESTDIR="'$pkgdir'/usr" install
} \ No newline at end of file
diff --git a/README.md b/README.md
index 449d0e22ebbb..5a1336cb5eef 100644
--- a/README.md
+++ b/README.md
@@ -92,4 +92,5 @@ and portfolio distribution (tried to implement, but IEX API is unpredictable; wa
* Make printouts pretty with ncurses (graph plots with historical prices?)
* Format prices with commas (set locale?)
* Function to add new attributes to portfolio if not found
-* Maybe replace News API with IEX news endpoint \ No newline at end of file
+* Maybe replace News API with IEX news endpoint
+* Bookmark certain stocks (not included in portfolio) \ No newline at end of file