aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-05-03 23:47:47 -0400
committerAntony Kellermann2018-05-03 23:47:47 -0400
commitcac8346661e7c7918acbbe7c64e5a890af6df555 (patch)
tree9a65cb64060ee5bc00f2825290aa95f8b4d5822d
parent021f755b48468b4a998dbcd421294fc552bad52d (diff)
downloadaur-cac8346661e7c7918acbbe7c64e5a890af6df555.tar.gz
Updated man page and new version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md17
-rw-r--r--tick.117
4 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e84df67114e..cd2d248bdfac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tick
pkgdesc = Command line stock and cryptocurrency portfolio tracker.
- pkgver = 1.13.0
+ pkgver = 1.14.0
pkgrel = 1
url = https://github.com/aokellermann/tick
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 235d4fbc986b..22e15195141d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antony Kellermann <aokellermann@gmail.com>
pkgname=tick
-pkgver=1.13.0
+pkgver=1.14.0
pkgrel=1
pkgdesc="Command line stock and cryptocurrency portfolio tracker."
arch=('x86_64')
diff --git a/README.md b/README.md
index 099fec544cf9..67871b3702c5 100644
--- a/README.md
+++ b/README.md
@@ -39,10 +39,13 @@ tickers also being listed on the stock market, such as ETH.
To get info about your current holdings, run
```bash
-$ tick check [symbol/crypto_id/all]
+$ tick check [symbol/crypto_id/sort_option]
```
-The string "all" will list your entire portfolio, as well as produce a grand
-total. Running "check" with no other arguments will also list your entire portfolio.
+Running "check" with no other arguments will list your entire portfolio
+as well as produce a grand total. Adding the argument "-v", "-p", or "-1"
+will sort the output by value, profit, or one day profit. To check a single
+security, use the symbol or crypto_id as the argument instead of sort
+options.
You may encrypt your portfolio using the RC4 algorithm
```bash
@@ -64,7 +67,8 @@ $ tick info tsla
The graph command will print out a graph in your terminal of the historic
price of the given security. Cryptocurrencies aren't supported yet, due to
API constraints. You may press the UP arrow key to zoom in, the DOWN arrow
-key to zoom out, or the letter "q" to quit.
+key to zoom out, the LEFT arrow to pan left, the RIGHT arrow to pan right,
+or the letter "q" to quit.
```bash
$ tick graph tsla
```
@@ -90,7 +94,6 @@ not abuse the APIs by repeatedly requesting information. Read the provided
license for more information.
#### Future Ideas/To-do
* Historical support -- 7d/28d profits (wait for coinmarketcap historical release)
-* Different ways to sort "check all"
* Look for API to replace Morningstar for MUTF/OTCMKTS data, preferably with
intraday data (wait for iex v2 probably)
* DEB/RPM package
@@ -100,4 +103,6 @@ and portfolio distribution (tried to implement, but IEX API is unpredictable; wa
* Function to add new attributes to portfolio if not found
* Maybe replace News API with IEX news endpoint
* Bookmark certain stocks (not included in portfolio)
-* Zoom in more than one month for graph \ No newline at end of file
+* Zoom in more than one month for graph
+* Average graph points when skipping indices for greater accuracy
+* Android app? \ No newline at end of file
diff --git a/tick.1 b/tick.1
index 64238d99ac22..692423ba1a97 100644
--- a/tick.1
+++ b/tick.1
@@ -1,4 +1,4 @@
-.TH TICK "1" "March 2018" "Tick 1.13.0" "User Commands"
+.TH TICK "1" "May 2018" "Tick 1.14.0" "User Commands"
.SH NAME
Tick - Command line stock and cryptocurrency portfolio tracker.
@@ -26,10 +26,11 @@ are not reinvested into a specific security, you should update your portfolio wi
You may also specify the share price instead of the total amount you spent by appending "ea" to the end of the share price.
.TP
-[check] [currency name/crypto_id/all]
-Prints information about your current portfolio holdings. Either a symbol or the keyword 'all' can be used. The keyword "all"
-will print information about all your current holdings, as well as a grand total. Running only 'tick check' will do the same
-thing as 'tick check all'.
+[check] [symbol/crypto_id/sort_option]
+Prints information about your current portfolio holdings. To print all of your holdings alphabetically as well as a
+grand total, no additional arguments besides "check" need to be used. Optionally, you may use the options "-a" to print
+alphabetically, "-v" to print by value, "-p" toprint by profit, or "-1" to print by one day profit. To print information
+about a single security, use the ticker or crypto id as an argument after "check".
.TP
[encrypt/decrypt]
@@ -74,7 +75,11 @@ $ tick check tsla
.RE
Or to get info about all your holdings, run
.RS
-$ tick check all
+$ tick check
+.RE
+or to sort by value
+.RS
+$ tick check -v
.RE
To get the top three news articles on Tesla in the past two weeks, run