summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbin2021-02-03 07:11:12 -0600
committerbin2021-02-03 07:11:12 -0600
commitdcf84118207d63ad923344894df9a747a941ca7c (patch)
treee0d4b71c79d0cfdcf2c1da9544f7008f628b2d01
downloadaur-dcf84118207d63ad923344894df9a747a941ca7c.tar.gz
v2.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae09f204f21b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ticker
+ pkgdesc = Terminal stock ticker with live updates and position tracking
+ pkgver = 2.1.0
+ pkgrel = 0
+ url = https://github.com/achannarasappa/ticker
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ depends = glibc
+ source = https://github.com/achannarasappa/ticker/archive/v2.1.0.tar.gz
+ sha256sums = 0edfc51c1cecd027975b6b88a44f148d0fb4ca1e2a1a9e9e22bef53260af1379
+
+pkgname = ticker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba3d6c047fe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=ticker
+pkgver=2.1.0
+pkgrel=0
+pkgdesc='Terminal stock ticker with live updates and position tracking'
+arch=('i686' 'x86_64')
+url="https://github.com/achannarasappa/ticker"
+license=('GPL')
+depends=('glibc')
+makedepends=('go')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('0edfc51c1cecd027975b6b88a44f148d0fb4ca1e2a1a9e9e22bef53260af1379')
+
+prepare () {
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build () {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build/$pkgname main.go
+}
+
+check () {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package () {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}