summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlothar-mar2015-06-11 15:58:02 +0100
committerlothar-mar2015-06-11 15:58:02 +0100
commitee70aecb0abf036c1c704a918886566939b8b01c (patch)
tree4c1a7956ab19b7810686d2803d4e5e477ca54951
downloadaur-ee70aecb0abf036c1c704a918886566939b8b01c.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25c5cf20f6d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ticker-git
+ pkgdesc = Ticker is a program that scrolls a message across the top or bottom line of your screen, in a manner similar to a stock ticker. Ticker supports communicating with programs that changes the text periodically.
+ pkgver = 1.9.r5.g51260c4
+ pkgrel = 1
+ url = http://joeyh.name/code/ticker/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = slang
+ provides = ticker
+ conflicts = ticker
+ source = git://git.kitenet.net/ticker
+ md5sums = SKIP
+
+pkgname = ticker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63da10bf5df0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+#Maintainer: Lothar_m <lothar_m at riseup dot net>
+
+pkgname='ticker-git'
+_gitname='ticker'
+pkgver=1.9.r5.g51260c4
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://joeyh.name/code/ticker/"
+depends=('slang')
+makedepends=('git')
+license=('GPL')
+pkgdesc="Ticker is a program that scrolls a message across the top or bottom line of your screen, in a manner similar to a stock ticker. Ticker supports communicating with programs that changes the text periodically."
+provides=(ticker)
+conflicts=(ticker)
+source=("git://git.kitenet.net/ticker"
+ )
+md5sums=('SKIP'
+ )
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # Use tag of the last commit, but removing the prefix
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_gitname}"
+ cd "$srcdir/$_gitname"
+
+ # building ....
+ ./configure --prefix=/usr
+ make
+}
+
+
+package() {
+ # install executable
+ install -D -m755 "$srcdir/$_gitname/ticker" "$pkgdir/usr/bin/ticker"
+
+ # install license
+ install -D -m644 "$srcdir/$_gitname/GPL" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}