summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspikecodes2020-10-18 18:08:35 -0700
committerspikecodes2020-10-18 18:08:35 -0700
commit349088556ff3f592fb3275896ab7795af397f243 (patch)
tree46c6fb0a4d27b8d500158844845f4da7469cdc0a
downloadaur-349088556ff3f592fb3275896ab7795af397f243.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2311d075aae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tickrs-git
+ pkgdesc = Realtime ticker data in your terminal 📈
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/tarkah/tickrs
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ provides = tickrs
+ conflicts = tickrs
+ source = tickrs::git+https://github.com/tarkah/tickrs
+ sha256sums = SKIP
+
+pkgname = tickrs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7cc69148aa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: spikecodes <19519553+spikecodes@users.noreply.github.com>
+pkgname=tickrs-git
+_pkgname=${pkgname%-git}
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Realtime ticker data in your terminal 📈"
+arch=('any')
+url="https://github.com/tarkah/tickrs"
+license=("MIT")
+makedepends=("git" "cargo")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${_pkgname}::git+${url}")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ printf "$(git describe --tags | awk -F- '{print $1}' | cut -c2-)"
+ )
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ install -Dm755 "${_pkgname}/target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}