summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongqi Yu2022-10-22 17:48:02 +0800
committerHongqi Yu2022-10-22 17:48:02 +0800
commit75d7123244da44a0ddaa161fd03a6395214e0a57 (patch)
treeac5d095da208de7292504275fd00575489a6b26b
downloadaur-75d7123244da44a0ddaa161fd03a6395214e0a57.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD38
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baa3a0e373f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ticli-git
+ pkgdesc = A modern cli for tikv
+ pkgver = 0.1.0.20221022
+ pkgrel = 1
+ url = https://https://github.com/hackathon-2022-ticli/ticli
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = APACHE
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ provides = ticli
+ conflicts = ticli
+ conflicts = ticli-bin
+ source = ticli::git+https://https://github.com/hackathon-2022-ticli/ticli
+ sha256sums = SKIP
+
+pkgname = ticli-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ee591e8bed32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4a946251ae5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Wenxuan <wenxuangm@gmail.com>
+# Maintainer: Hongqi Yu <bowser1704@gmail.com>
+_pkgname=ticli
+pkgname=ticli-git
+pkgver=0.1.0.20221022
+pkgrel=1
+pkgdesc='A modern cli for tikv'
+arch=(i686 x86_64)
+url='https://https://github.com/hackathon-2022-ticli/ticli'
+license=('MIT' 'APACHE')
+makedepends=('git' 'rust' 'cargo')
+conflicts=("${_pkgname}" "${_pkgname}-bin")
+provides=("${_pkgname}")
+
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ echo "$(grep -oPm1 '(?<=^version = ")[^"]+' Cargo.toml).$(TZ=UTC git log -1 --pretty='%cd' --date=short-local | tr -d '-')" | tr '-' '.'
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release --locked
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ install -Dm755 "target/release/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm644 "completions/fish/${_pkgname}.fish" "$pkgdir/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
+ install -Dm644 "completions/zsh/_${_pkgname}" "$pkgdir/usr/share/zsh/site-functions/_${_pkgname}"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+ install -Dm644 "LICENSE-APACHE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-APACHE"
+}
+
+# vim:set noet sts=0 sw=4 ts=4 ft=PKGBUILD: