summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthrea4ctor2021-12-23 17:57:53 +0100
committerGitHub2021-12-23 17:57:53 +0100
commit166b0f84811a3d054d395fbd932c01950bf71857 (patch)
tree2044d7d9c708f95078d47591f8d483b7d2d2a830
parentb6addedda8a0a548f4799f2112fa0e66b02d2967 (diff)
downloadaur-166b0f84811a3d054d395fbd932c01950bf71857.tar.gz
make sure npm is available in the env when building
There was the proper environment missing in the build() routine when npm wasn't installed globally. This led the build fail because `npm` could not be found. Calling getnvm to source the NVM env fixes it.
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5943f3d67198..5bd0651ec61a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,6 +60,8 @@ prepare() {
}
build() {
+ getnvm
+
cd "${srcdir}/${pkgname%-git}"
# We are not using the systems Electron as we need castlab's Electron.