summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastermindzh2022-06-18 11:23:50 +0200
committerMastermindzh2022-06-18 11:23:50 +0200
commit9416e128352bc98ed1d04650297a97835a6f6589 (patch)
tree4cddd8d7925b6bda62bd54a3890f571d1701bfdd
parentd8f8d3031c3fa0f49c54d77ff7d8a2ce536ac48d (diff)
parente8f239da991811d86555f030720a17d862e98c43 (diff)
downloadaur-9416e128352bc98ed1d04650297a97835a6f6589.tar.gz
Merge branch 'master' of github.com:Mastermindzh/tidal-hifi-aur
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD32
2 files changed, 32 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7c7970bbbeb..8599ff4b8629 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = tidal-hifi-git
- pkgdesc = The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm
- pkgver = 3.1.1.r0.g8f47756
- pkgrel = 1
- url = https://github.com/Mastermindzh/tidal-hifi
- arch = x86_64
- license = custom:MIT
- makedepends = git
- depends = libxss
- depends = nss
- depends = gtk3
- depends = libxcrypt-compat
- provides = tidal-hifi
- conflicts = tidal-hifi
- source = git+https://github.com/Mastermindzh/tidal-hifi.git
- source = tidal-hifi.desktop
- sha512sums = SKIP
- sha512sums = 31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1
+pkgdesc = The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm
+pkgver = 3.1.1.r0.g8f47756
+pkgrel = 1
+url = https://github.com/Mastermindzh/tidal-hifi
+arch = x86_64
+license = custom:MIT
+makedepends = git
+depends = libxss
+depends = nss
+depends = gtk3
+depends = libxcrypt-compat
+provides = tidal-hifi
+conflicts = tidal-hifi
+source = git+https://github.com/Mastermindzh/tidal-hifi.git
+source = tidal-hifi.desktop
+sha512sums = SKIP
+sha512sums = 31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1
pkgname = tidal-hifi-git
diff --git a/PKGBUILD b/PKGBUILD
index 1a159551d3b0..bb23e944ad82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,18 +13,16 @@ provides=(tidal-hifi)
conflicts=(tidal-hifi)
source=("git+https://github.com/Mastermindzh/tidal-hifi.git"
-"tidal-hifi.desktop")
+ "tidal-hifi.desktop")
sha512sums=('SKIP'
-'31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1')
+ '31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1')
getnvm() {
- if command -v nvm
- then
+ if command -v nvm; then
echo "nvm command found, using system version.."
else
-
- if test -f "/usr/share/nvm/init-nvm.sh"
- then
+
+ if test -f "/usr/share/nvm/init-nvm.sh"; then
echo "found init-nvm.sh in /usr/share/nvm, sourcing..."
unset npm_config_prefix
source "/usr/share/nvm/init-nvm.sh"
@@ -49,39 +47,39 @@ pkgver() {
prepare() {
getnvm
-
+
cd "${srcdir}/${pkgname%-git}" || exit
-
+
# use correct nodejs/npm versions
nvm install lts/gallium
nvm use lts/gallium
-
+
# install build dependencies
npm install
}
build() {
getnvm
-
+
cd "${srcdir}/${pkgname%-git}" || exit
-
+
# We are not using the systems Electron as we need castlab's Electron.
npm run build-arch
}
package() {
cd "${srcdir}/${pkgname%-git}" || exit
-
+
install -d "${pkgdir}/opt/tidal-hifi/" "${pkgdir}/usr/bin" "${pkgdir}/usr/share/doc" "${pkgdir}/usr/share/licenses"
-
+
cp -r dist/linux-unpacked/* "${pkgdir}/opt/tidal-hifi/"
chmod +x "${pkgdir}/opt/tidal-hifi/tidal-hifi"
-
+
ln -s "/opt/tidal-hifi/tidal-hifi" "${pkgdir}/usr/bin/tidal-hifi"
-
+
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/pixmaps/tidal-hifi.png"
install -Dm 644 "${srcdir}/tidal-hifi.desktop" "${pkgdir}/usr/share/applications/tidal-hifi.desktop"
-
+
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"