summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastermindzh2023-01-22 23:27:32 +0100
committerMastermindzh2023-01-22 23:27:32 +0100
commitaf017c6e97a8158cd9335f298fd9dd8cb69d4605 (patch)
treecdb1af17b9554eee64268d5f3487c14bd9323410
parent1bd623ee0818fe80d12c5206fc99896b22268673 (diff)
parenta30471d5d42de570fddf97cc6a6081ae269a632b (diff)
downloadaur-af017c6e97a8158cd9335f298fd9dd8cb69d4605.tar.gz
Merge branch 'master' of github.com:Mastermindzh/tidal-hifi-aur
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--tidal-hifi.desktop11
-rw-r--r--tidal-hifi.xml6
5 files changed, 55 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b513308da8..88b077045481 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = tidal-hifi-git
- pkgdesc = The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm
- pkgver = 4.4.0.r0.gd0f9a34
- pkgrel = 1
- url = https://github.com/Mastermindzh/tidal-hifi
- arch = x86_64
- license = custom:MIT
- makedepends = git
- depends = libxss
- depends = nss
- depends = gtk3
- depends = libxcrypt-compat
- provides = tidal-hifi
- conflicts = tidal-hifi
- source = git+https://github.com/Mastermindzh/tidal-hifi.git
- source = tidal-hifi.desktop
- sha512sums = SKIP
- sha512sums = 31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1
+ pkgdesc = The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm
+ pkgver = 4.4.0.r0.gd0f9a34
+ pkgrel = 1
+ url = <https://github.com/Mastermindzh/tidal-hifi>
+ arch = x86_64
+ license = custom:MIT
+ makedepends = git
+ depends = libxss
+ depends = nss
+ depends = gtk3
+ depends = libxcrypt-compat
+ provides = tidal-hifi
+ conflicts = tidal-hifi
+ source = git+<https://github.com/Mastermindzh/tidal-hifi.git>
+ source = tidal-hifi.desktop
+ source = tidal-hifi.xml
+ sha512sums = SKIP
+ sha512sums = 20dc16dfd79cd00686b29bc621c64568b6557d73da5b7c1fba7dee0277784cc6f133520ca55d83fb878c3e5cc6734b6fd1b47502366a8907113625ce4e362bbc
+ sha512sums = e06fce55c2d9fcaeff514b97e8b003dca4c1a0aa8c8e14c3e3b99febbc2e8af7402d2e2009147f3f57a9b6447fafd23dd69e7b4de63cf43c5d67825836ebecb5
pkgname = tidal-hifi-git
diff --git a/.gitignore b/.gitignore
index ec30db987615..adfd27304805 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,6 @@
!package.json
!PKGBUILD
!tidal-hifi.desktop
-!src/tidal-hifi.desktop \ No newline at end of file
+!src/tidal-hifi.desktop
+!tidal-hifi.xml
+!src/tidal-hifi.xml
diff --git a/PKGBUILD b/PKGBUILD
index cfa8ef1ded5f..be5b8fbbdb93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,18 +13,18 @@ provides=(tidal-hifi)
conflicts=(tidal-hifi)
source=("git+https://github.com/Mastermindzh/tidal-hifi.git"
-"tidal-hifi.desktop")
+ "tidal-hifi.desktop"
+ "tidal-hifi.xml")
sha512sums=('SKIP'
-'31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1')
+ '20dc16dfd79cd00686b29bc621c64568b6557d73da5b7c1fba7dee0277784cc6f133520ca55d83fb878c3e5cc6734b6fd1b47502366a8907113625ce4e362bbc'
+ "e06fce55c2d9fcaeff514b97e8b003dca4c1a0aa8c8e14c3e3b99febbc2e8af7402d2e2009147f3f57a9b6447fafd23dd69e7b4de63cf43c5d67825836ebecb5")
getnvm() {
- if command -v nvm
- then
+ if command -v nvm; then
echo "nvm command found, using system version.."
else
-
- if test -f "/usr/share/nvm/init-nvm.sh"
- then
+
+ if test -f "/usr/share/nvm/init-nvm.sh"; then
echo "found init-nvm.sh in /usr/share/nvm, sourcing..."
unset npm_config_prefix
source "/usr/share/nvm/init-nvm.sh"
@@ -49,42 +49,46 @@ pkgver() {
prepare() {
getnvm
-
+
cd "${srcdir}/${pkgname%-git}" || exit
-
+
# use correct nodejs/npm versions
nvm install lts/gallium
nvm use lts/gallium
-
+
# install build dependencies
npm install
}
build() {
getnvm
-
+
cd "${srcdir}/${pkgname%-git}" || exit
-
+
# We are not using the systems Electron as we need castlab's Electron.
npm run build-arch
}
package() {
cd "${srcdir}/${pkgname%-git}" || exit
-
+
install -d "${pkgdir}/opt/tidal-hifi/" "${pkgdir}/usr/bin" "${pkgdir}/usr/share/doc" "${pkgdir}/usr/share/licenses"
-
+
cp -r dist/linux-unpacked/* "${pkgdir}/opt/tidal-hifi/"
chmod +x "${pkgdir}/opt/tidal-hifi/tidal-hifi"
-
+
ln -s "/opt/tidal-hifi/tidal-hifi" "${pkgdir}/usr/bin/tidal-hifi"
-
+
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/pixmaps/tidal-hifi.png"
+ install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/${pkgname%-git}/tidal-hifi.png"
+ install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"
install -Dm 644 "${srcdir}/tidal-hifi.desktop" "${pkgdir}/usr/share/applications/tidal-hifi.desktop"
-
+ install -Dm 644 "${srcdir}/tidal-hifi.xml" "${pkgdir}/usr/share/mime/packages/tidal-hifi.xml"
+
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"
+
ln -s "/opt/tidal-hifi/LICENSE.electron.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.electron.txt"
ln -s "/opt/tidal-hifi/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES.chromium.html"
}
diff --git a/tidal-hifi.desktop b/tidal-hifi.desktop
index 71793079aa1a..d8f127e7ee84 100644
--- a/tidal-hifi.desktop
+++ b/tidal-hifi.desktop
@@ -1,13 +1,14 @@
[Desktop Entry]
Encoding=UTF-8
-Name=tidal-hifi
-GenericName=tidal-hifi
+Name=TIDAL Hi-Fi
+GenericName=TIDAL Hi-Fi
Comment=The web version of listen.tidal.com running in electron with hifi support thanks to widevine.
Exec=tidal-hifi %u
-Icon=/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png
+Icon=/usr/share/icons/tidal-hifi/tidal-hifi.png
StartupNotify=true
Terminal=false
Type=Application
-Categories=Network;Application;Audio;Video
+Categories=Network;Application;Audio;Video;AudioVideo
StartupWMClass=tidal-hifi
-X-PulseAudio-Properties=media.role=music \ No newline at end of file
+X-PulseAudio-Properties=media.role=music
+MimeType=x-scheme-handler/tidal; \ No newline at end of file
diff --git a/tidal-hifi.xml b/tidal-hifi.xml
new file mode 100644
index 000000000000..388db9b94659
--- /dev/null
+++ b/tidal-hifi.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="utf-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="x-scheme-handler/tidal">
+ <icon name="tidal-hifi" />
+ </mime-type>
+</mime-info> \ No newline at end of file