summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastermindzh2021-12-19 13:44:15 +0100
committerMastermindzh2021-12-19 13:44:15 +0100
commitb6addedda8a0a548f4799f2112fa0e66b02d2967 (patch)
treef54a03a76c5601f54009ae27c9fd153cd6f74ae7
parentc1a999af2f38a5663e08f49fd06d78f1b8e0a462 (diff)
downloadaur-b6addedda8a0a548f4799f2112fa0e66b02d2967.tar.gz
2.6.0 release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 054fc55c8a22..f922252652ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tidal-hifi-git
pkgdesc = The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm
- pkgver = 2.5.0.r0.g662ef6a
- pkgrel = 2
+ pkgver = 2.6.0.r0.g0dec967
+ pkgrel = 1
url = https://github.com/Mastermindzh/tidal-hifi
arch = x86_64
license = custom:MIT
diff --git a/PKGBUILD b/PKGBUILD
index e21f0a1b5798..5943f3d67198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Rick van Lieshout <info@rickvanlieshout.com>
pkgname=tidal-hifi-git
-pkgrel=2
-pkgver=2.5.0.r0.g662ef6a
+pkgrel=1
+pkgver=2.6.0.r0.g0dec967
pkgdesc="The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm"
arch=(x86_64)
url="https://github.com/Mastermindzh/tidal-hifi"
@@ -22,15 +22,22 @@ getnvm() {
then
echo "nvm command found, using system version.."
else
- echo "nvm could not be found, installing"
- unset npm_config_prefix
- folderName=$(cat /dev/urandom | tr -cd 'a-f0-9' | head -c 12)
- git clone https://aur.archlinux.org/nvm.git "$folderName"
- cd "$folderName"
- makepkg -si --asdeps
- source /usr/share/nvm/init-nvm.sh
- cd ../
- rm -rf "$folderName"
+
+ if test -f "/usr/share/nvm/init-nvm.sh"
+ then
+ echo "found init-nvm.sh in /usr/share/nvm, sourcing..."
+ source "/usr/share/nvm/init-nvm.sh"
+ else
+ echo "nvm could not be found, installing"
+ unset npm_config_prefix
+ folderName=$(cat /dev/urandom | tr -cd 'a-f0-9' | head -c 12)
+ git clone https://aur.archlinux.org/nvm.git "$folderName"
+ cd "$folderName"
+ makepkg -si --asdeps
+ source /usr/share/nvm/init-nvm.sh
+ cd ../
+ rm -rf "$folderName"
+ fi
fi
}