summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastermindzh2021-12-08 17:44:24 +0100
committerMastermindzh2021-12-08 17:44:24 +0100
commitbff53b3f5119fe7edae4fb0c4186310d9c3fa4ed (patch)
treefd9711577049ff2c94108cc8742aab5ee9876670
parentbdc296a02c2e124dfe0b66912b8f254caec9d638 (diff)
downloadaur-bff53b3f5119fe7edae4fb0c4186310d9c3fa4ed.tar.gz
updated package build to use random folder for nvm
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1392254934e5..e21f0a1b5798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rick van Lieshout <info@rickvanlieshout.com>
pkgname=tidal-hifi-git
-pkgrel=1
+pkgrel=2
pkgver=2.5.0.r0.g662ef6a
pkgdesc="The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm"
arch=(x86_64)
@@ -24,12 +24,13 @@ getnvm() {
else
echo "nvm could not be found, installing"
unset npm_config_prefix
- git clone https://aur.archlinux.org/nvm.git .nvmdep
- cd .nvmdep
+ folderName=$(cat /dev/urandom | tr -cd 'a-f0-9' | head -c 12)
+ git clone https://aur.archlinux.org/nvm.git "$folderName"
+ cd "$folderName"
makepkg -si --asdeps
source /usr/share/nvm/init-nvm.sh
cd ../
- rm -rf .nvmdep
+ rm -rf "$folderName"
fi
}