summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastermindzh2022-08-07 16:54:53 +0200
committerMastermindzh2022-08-07 16:54:53 +0200
commitf9172ce849deb3a3f50054c4d8001b5cbf7d051a (patch)
tree1ec095edb9cee0dcc632626123a2d66f7c20fdd0
parent723b210494040d9b386b941a8a0a7e4482b44092 (diff)
downloadaur-f9172ce849deb3a3f50054c4d8001b5cbf7d051a.tar.gz
4.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
-rw-r--r--tidal-hifi.desktop5
-rw-r--r--tidal-hifi.xml6
5 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0924649dcf2c..98e1ccb0d2df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tidal-hifi-git
pkgdesc = The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm
- pkgver = 4.0.1.r0.gfa9ab22
- pkgrel = 2
+ pkgver = 4.1.0.r0.g1439a11
+ pkgrel = 1
url = https://github.com/Mastermindzh/tidal-hifi
arch = x86_64
license = custom:MIT
@@ -14,7 +14,9 @@ pkgbase = tidal-hifi-git
conflicts = tidal-hifi
source = git+https://github.com/Mastermindzh/tidal-hifi.git
source = tidal-hifi.desktop
+ source = tidal-hifi.xml
sha512sums = SKIP
- sha512sums = 31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1
+ sha512sums = 402a73f4bc4c543208d518044607af8b71da428d58b37397a2d74bad1f0d4b854a0a037fd2d29ac157e7185165afe13865a87c57abe8019617de73a767087918
+ sha512sums = e06fce55c2d9fcaeff514b97e8b003dca4c1a0aa8c8e14c3e3b99febbc2e8af7402d2e2009147f3f57a9b6447fafd23dd69e7b4de63cf43c5d67825836ebecb5
pkgname = tidal-hifi-git
diff --git a/.gitignore b/.gitignore
index ec30db987615..adfd27304805 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,6 @@
!package.json
!PKGBUILD
!tidal-hifi.desktop
-!src/tidal-hifi.desktop \ No newline at end of file
+!src/tidal-hifi.desktop
+!tidal-hifi.xml
+!src/tidal-hifi.xml
diff --git a/PKGBUILD b/PKGBUILD
index 082d758e0889..7c5b4d727ba0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Rick van Lieshout <info@rickvanlieshout.com>
pkgname=tidal-hifi-git
-pkgrel=2
-pkgver=4.0.1.r0.gfa9ab22
+pkgrel=1
+pkgver=4.1.0.r0.g1439a11
pkgdesc="The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm"
arch=(x86_64)
url="https://github.com/Mastermindzh/tidal-hifi"
@@ -13,9 +13,11 @@ provides=(tidal-hifi)
conflicts=(tidal-hifi)
source=("git+https://github.com/Mastermindzh/tidal-hifi.git"
- "tidal-hifi.desktop")
+ "tidal-hifi.desktop"
+ "tidal-hifi.xml")
sha512sums=('SKIP'
- '31cf40fb3ac81c4a64a8410a78e97c268a440577bce54347ce62f8a9566c8897f8083cd1e5afa40b0fbe9a149fc4fb4f29cad91a12e5b47cf8e300e56351a4f1')
+ '402a73f4bc4c543208d518044607af8b71da428d58b37397a2d74bad1f0d4b854a0a037fd2d29ac157e7185165afe13865a87c57abe8019617de73a767087918'
+ "e06fce55c2d9fcaeff514b97e8b003dca4c1a0aa8c8e14c3e3b99febbc2e8af7402d2e2009147f3f57a9b6447fafd23dd69e7b4de63cf43c5d67825836ebecb5")
getnvm() {
if command -v nvm; then
@@ -78,11 +80,15 @@ package() {
ln -s "/opt/tidal-hifi/tidal-hifi" "${pkgdir}/usr/bin/tidal-hifi"
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/pixmaps/tidal-hifi.png"
+ install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/${_pkgname}/tidal-hifi.png"
+ install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"
install -Dm 644 "${srcdir}/tidal-hifi.desktop" "${pkgdir}/usr/share/applications/tidal-hifi.desktop"
+ install -Dm 644 "${srcdir}/tidal-hifi.xml" "${pkgdir}/usr/share/mime/packages/tidal-hifi.xml"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"
+
ln -s "/opt/tidal-hifi/LICENSE.electron.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.electron.txt"
ln -s "/opt/tidal-hifi/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES.chromium.html"
}
diff --git a/tidal-hifi.desktop b/tidal-hifi.desktop
index 71793079aa1a..27d30f751ece 100644
--- a/tidal-hifi.desktop
+++ b/tidal-hifi.desktop
@@ -4,10 +4,11 @@ Name=tidal-hifi
GenericName=tidal-hifi
Comment=The web version of listen.tidal.com running in electron with hifi support thanks to widevine.
Exec=tidal-hifi %u
-Icon=/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png
+Icon=/usr/share/icons/tidal-hifi/tidal-hifi.png
StartupNotify=true
Terminal=false
Type=Application
Categories=Network;Application;Audio;Video
StartupWMClass=tidal-hifi
-X-PulseAudio-Properties=media.role=music \ No newline at end of file
+X-PulseAudio-Properties=media.role=music
+MimeType=x-scheme-handler/tidal; \ No newline at end of file
diff --git a/tidal-hifi.xml b/tidal-hifi.xml
new file mode 100644
index 000000000000..388db9b94659
--- /dev/null
+++ b/tidal-hifi.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="utf-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="x-scheme-handler/tidal">
+ <icon name="tidal-hifi" />
+ </mime-type>
+</mime-info> \ No newline at end of file