summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2020-07-02 13:41:53 +0800
committerAllen Zhong2020-07-02 13:41:53 +0800
commit48bc5b7e606a2633a5e93ec9627ec82809a7251b (patch)
tree2f6c450999c43cdffe589aea74e09aa8b6f44fe7
parent401d60fefbfd1f2d7b50961fdf6b6b78baef7705 (diff)
downloadaur-48bc5b7e606a2633a5e93ec9627ec82809a7251b.tar.gz
upgpkg: tidb 4.0.2-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--tidb.install10
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 278f7bd33427..cac0b82d39f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = tidb
pkgdesc = A distributed HTAP database compatible with the MySQL protocol
- pkgver = 4.0.0
+ pkgver = 4.0.2
pkgrel = 1
url = https://github.com/pingcap/tidb
+ install = tidb.install
arch = x86_64
license = Apache
makedepends = go
@@ -10,12 +11,12 @@ pkgbase = tidb
depends = tikv
provides = tidb-server
backup = etc/tidb/tidb.toml
- source = tidb-4.0.0.tar.gz::https://github.com/pingcap/tidb/archive/v4.0.0.tar.gz
+ source = tidb-4.0.2.tar.gz::https://github.com/pingcap/tidb/archive/v4.0.2.tar.gz
source = tidb.service
source = tidb-sysusers.conf
source = tidb-tmpfiles.conf
source = tidb.toml
- sha256sums = 750f00f8fee52c628e9e8f808d8b49b411f84fb0f7b95949ab4eaa51f8768732
+ sha256sums = 20feec84244799522c457abf16c0c5b1095659a5e3ddaf131122f4ad539efa77
sha256sums = 22318c19bb89ff5a0852df5186cc1496214cd49f2264192413a326d1e8c93dc9
sha256sums = 2b147d80985e714d5f861baf76591104c07058b9b6fa573bf0676d675cf8fc20
sha256sums = 30ce83fbec8f102c30e438282bb5b18c026d08480f2386d68f1116c12481bf66
diff --git a/PKGBUILD b/PKGBUILD
index 65e422fe4a7d..2242b9d59a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
# Maintainer: Allen Zhong <zhongbenli@pingcap.com>
pkgname=tidb
-pkgver=4.0.0
+pkgver=4.0.2
pkgrel=1
pkgdesc='A distributed HTAP database compatible with the MySQL protocol'
makedepends=('go' 'make')
@@ -11,12 +11,13 @@ license=('Apache')
provides=('tidb-server')
backup=(etc/tidb/tidb.toml)
depends=('tikv')
+install=tidb.install
source=(tidb-${pkgver}.tar.gz::https://github.com/pingcap/tidb/archive/v${pkgver}.tar.gz
tidb.service
tidb-sysusers.conf
tidb-tmpfiles.conf
tidb.toml)
-sha256sums=('750f00f8fee52c628e9e8f808d8b49b411f84fb0f7b95949ab4eaa51f8768732'
+sha256sums=('20feec84244799522c457abf16c0c5b1095659a5e3ddaf131122f4ad539efa77'
'22318c19bb89ff5a0852df5186cc1496214cd49f2264192413a326d1e8c93dc9'
'2b147d80985e714d5f861baf76591104c07058b9b6fa573bf0676d675cf8fc20'
'30ce83fbec8f102c30e438282bb5b18c026d08480f2386d68f1116c12481bf66'
@@ -34,6 +35,7 @@ prepare() {
build() {
export GOPATH="$srcdir/build"
export PATH=$GOPATH/bin:$PATH
+ export CGO_LDFLAGS="${LDFLAGS}"
cd $GOPATH/src/$_gopkgname
diff --git a/tidb.install b/tidb.install
new file mode 100644
index 000000000000..480099888ff2
--- /dev/null
+++ b/tidb.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ if [[ $(vercmp $2 4.0.2-1) -le 0 ]]; then
+ echo ':: NOTICE:'
+ echo ' - Starting from v4.0.2, TiDB components has added a new telemetry'
+ echo ' feature enabled by default, which will send usage information'
+ echo ' of TiDB clusters to PingCAP.'
+ echo ' See the official documentation about what is collected and how to'
+ echo ' disable it: https://docs.pingcap.com/tidb/v4.0/telemetry'
+ fi
+}