summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2024-03-27 03:03:50 +0900
committerAllen Zhong2024-03-27 03:03:50 +0900
commit62f8eaba4eca619b96f230b4e07ea00a96aa711b (patch)
tree676a89f61c4d2e09e54d38249af17e7671f28619
parent149aac3da969e373597f6cd5c3ac90ae8bdc5742 (diff)
downloadaur-62f8eaba4eca619b96f230b4e07ea00a96aa711b.tar.gz
bump 7.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a6ecd2d23bd..5dcfc3c9692d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tidb
pkgdesc = A distributed HTAP database compatible with the MySQL protocol
- pkgver = 5.4.0
+ pkgver = 7.6.0
pkgrel = 1
url = https://github.com/pingcap/tidb
install = tidb.install
@@ -11,12 +11,12 @@ pkgbase = tidb
depends = tikv
provides = tidb-server
backup = etc/tidb/tidb.toml
- source = tidb-5.4.0.tar.gz::https://github.com/pingcap/tidb/archive/v5.4.0.tar.gz
+ source = tidb-7.6.0.tar.gz::https://github.com/pingcap/tidb/archive/v7.6.0.tar.gz
source = tidb.service
source = tidb-sysusers.conf
source = tidb-tmpfiles.conf
source = tidb.toml
- sha256sums = 4435212a76e9fb4358f4a00bc19469fbcdf5368f5b7fff95cb960be31ed2a05a
+ sha256sums = f7c9c022b8fc5c038693bfde67d1f360f3295161789abae5768534aea1fa42a5
sha256sums = 22318c19bb89ff5a0852df5186cc1496214cd49f2264192413a326d1e8c93dc9
sha256sums = 2b147d80985e714d5f861baf76591104c07058b9b6fa573bf0676d675cf8fc20
sha256sums = 30ce83fbec8f102c30e438282bb5b18c026d08480f2386d68f1116c12481bf66
diff --git a/PKGBUILD b/PKGBUILD
index 4ef483118c4b..bbfe5f2b9c46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
-# Maintainer: Allen Zhong <zhongbenli@pingcap.com>
+# Maintainer: Allen Zhong <pdev@zhoal.pw>
pkgname=tidb
-pkgver=5.4.0
+pkgver=7.6.0
pkgrel=1
pkgdesc='A distributed HTAP database compatible with the MySQL protocol'
makedepends=('go' 'make')
@@ -17,7 +17,7 @@ source=(tidb-${pkgver}.tar.gz::https://github.com/pingcap/tidb/archive/v${pkgver
tidb-sysusers.conf
tidb-tmpfiles.conf
tidb.toml)
-sha256sums=('4435212a76e9fb4358f4a00bc19469fbcdf5368f5b7fff95cb960be31ed2a05a'
+sha256sums=('f7c9c022b8fc5c038693bfde67d1f360f3295161789abae5768534aea1fa42a5'
'22318c19bb89ff5a0852df5186cc1496214cd49f2264192413a326d1e8c93dc9'
'2b147d80985e714d5f861baf76591104c07058b9b6fa573bf0676d675cf8fc20'
'30ce83fbec8f102c30e438282bb5b18c026d08480f2386d68f1116c12481bf66'
@@ -46,7 +46,7 @@ build() {
cd $GOPATH/src/$_gopkgname
- _LDFLAGS="-X github.com/pingcap/parser/mysql.TiDBReleaseVersion=$pkgver -X $_gopkgname/util/versioninfo.TiDBGitHash=v$pkgver -X $_gopkgname/util/versioninfo.TiDBGitBranch=release"
+ _LDFLAGS="-X $_gopkgname/pkg/parser/mysql.TiDBReleaseVersion=$pkgver -X $_gopkgname/pkg/util/versioninfo.TiDBGitHash=v$pkgver -X $_gopkgname/pkg/util/versioninfo.TiDBGitBranch=release"
BUILD_FLAG=$GOFLAGS LDFLAGS=$_LDFLAGS make server
}