summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiqueur Librazy2016-10-31 07:08:31 +0800
committerLiqueur Librazy2016-10-31 07:08:31 +0800
commit3452266eac8475978f48eb5ce177a4582ccd2a39 (patch)
tree71eb5cb5e207133fc6354bc93c94223d289a5827
parent626227ee7ab7bd2991adbde62a5d901019eda3bd (diff)
downloadaur-3452266eac8475978f48eb5ce177a4582ccd2a39.tar.gz
UPDATE use rename to avoid outdated source cache
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f82867a24b16..e86912b59fd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = tidb-bin
pkgdesc = A distributed NewSQL database compatible with MySQL protocol
pkgver = 0.0.1.20161030052309
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pingcap/tidb
arch = x86_64
license = APACHE
depends = gcc-libs
- source = http://download.pingcap.org/tidb-latest-linux-amd64.tar.gz
source = http://download.pingcap.org/tidb-latest-linux-amd64.sha256
+ source = http://download.pingcap.org/tidb-latest-linux-amd64.tar.gz
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a9eab4f7b0ba..ff5fe33f1c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Liqueur Librazy <im@librazy.org>
pkgname=tidb-bin
pkgver=0.0.1.20161030052309
-pkgrel=1
+pkgrel=2
+
pkgdesc="A distributed NewSQL database compatible with MySQL protocol"
arch=('x86_64')
url="https://github.com/pingcap/tidb"
@@ -9,9 +10,9 @@ license=('APACHE')
depends=('gcc-libs')
backup=()
options=()
-
-source=("http://download.pingcap.org/tidb-latest-linux-amd64.tar.gz"
- "http://download.pingcap.org/tidb-latest-linux-amd64.sha256")
+_nametoday="${pkgname}-${pkgver}-$(date +%FT%T)"
+source=("${_nametoday}.sha256::http://download.pingcap.org/tidb-latest-linux-amd64.sha256"
+ "${_nametoday}.tar.gz::http://download.pingcap.org/tidb-latest-linux-amd64.tar.gz")
sha256sums=(
'SKIP'
@@ -23,7 +24,8 @@ pkgver() {
}
prepare() {
- sha256sum -c tidb-latest-linux-amd64.sha256
+ cp "${_nametoday}.tar.gz" "tidb-latest-linux-amd64.tar.gz"
+ sha256sum -c ${_nametoday}.sha256
}
package() {
@@ -33,6 +35,4 @@ package() {
cd ..
cp -R conf "$pkgdir/opt/tidb/"
cd ..
- rm tidb-latest-linux-amd64.tar.gz
- rm tidb-latest-linux-amd64.sha256
}