summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2019-03-01 15:03:21 +0800
committerAllen Zhong2019-03-01 15:03:21 +0800
commita9b035b889106b0cebd7b546290c6dce897973c0 (patch)
treefadce46fa36882caf0237a52c67fae26aaf49c8d
parent92941fe409e84ab737ea9bb9c3df604c1881a744 (diff)
downloadaur-a9b035b889106b0cebd7b546290c6dce897973c0.tar.gz
upgpkg: tidb-bin 2.1.4-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d38803882b47..4485280f1f3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tidb-bin
pkgdesc = A distributed NewSQL database compatible with MySQL protocol
- pkgver = 2.1.3
- pkgrel = 2
+ pkgver = 2.1.4
+ pkgrel = 1
url = https://github.com/pingcap/tidb
arch = x86_64
license = APACHE
@@ -12,7 +12,7 @@ pkgbase = tidb-bin
conflicts = tikv-pd
options = strip
options = debug
- source = https://download.pingcap.org/tidb-v2.1.3-linux-amd64.tar.gz
+ source = https://download.pingcap.org/tidb-v2.1.4-linux-amd64.tar.gz
source = pd.service
source = tidb.service
source = tikv.service
@@ -25,7 +25,7 @@ pkgbase = tidb-bin
source = pd.toml
source = tidb.toml
source = tikv.toml
- sha256sums = 95f6322f7a5724bde75a5f3d950602e0b0116768e52d9f49691c0fdc88f9b84d
+ sha256sums = 2e8481337c2ca9765491cf086c6a321844d15b6d5e9fffa9e25d30ceb5b2bb92
sha256sums = b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924
sha256sums = 22318c19bb89ff5a0852df5186cc1496214cd49f2264192413a326d1e8c93dc9
sha256sums = 870b8eaf83bc0d22b05b0f3a7890660e483cf77bb1d84bc50ad04fb23068cd8c
@@ -41,9 +41,9 @@ pkgbase = tidb-bin
pkgname = tidb-bin
install = tidb.install
- provides = tidb-server=2.1.3
- provides = tikv-server=2.1.3
- provides = pd-server=2.1.3
+ provides = tidb-server=2.1.4
+ provides = tikv-server=2.1.4
+ provides = pd-server=2.1.4
pkgname = tidb-bin-utils
optdepends = go-tools: provides goyacc
diff --git a/PKGBUILD b/PKGBUILD
index 2a94e1fb7036..981391374823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Jian Zeng <anonymousknight96@gmail.com>
# Contributor: Xuanwo <xuanwo@archlinuxcn.org>
pkgbase=tidb-bin
-_basever=2.1.3
+_basever=2.1.4
#_relver=-prega
#pkgver=$_basever.$_relver
pkgver=$_basever
-pkgrel=2
+pkgrel=1
pkgname=("${pkgbase}" "${pkgbase}-utils")
pkgdesc="A distributed NewSQL database compatible with MySQL protocol"
arch=('x86_64')
@@ -29,7 +29,7 @@ source=("https://download.pingcap.org/tidb-v$_basever$_relver-linux-amd64.tar.gz
pd.toml
tidb.toml
tikv.toml)
-sha256sums=('95f6322f7a5724bde75a5f3d950602e0b0116768e52d9f49691c0fdc88f9b84d'
+sha256sums=('2e8481337c2ca9765491cf086c6a321844d15b6d5e9fffa9e25d30ceb5b2bb92'
'b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924'
'22318c19bb89ff5a0852df5186cc1496214cd49f2264192413a326d1e8c93dc9'
'870b8eaf83bc0d22b05b0f3a7890660e483cf77bb1d84bc50ad04fb23068cd8c'
@@ -74,10 +74,14 @@ _package-utils() {
optdepends=('go-tools: provides goyacc')
cd "tidb-v$_basever$_relver-linux-amd64/bin"
install -dm755 "$pkgdir"/usr/bin
- install -Dm755 *-ctl "$pkgdir"/usr/bin
+ install -Dm755 *ctl "$pkgdir"/usr/bin
install -Dm755 pd-recover "$pkgdir"/usr/bin
install -Dm755 pd-tso-bench "$pkgdir"/usr/bin
install -Dm755 tikv-importer "$pkgdir"/usr/bin
+ install -Dm755 tidb-lightning* "$pkgdir"/usr/bin
+ install -Dm755 pump "$pkgdir"/usr/bin
+ install -Dm755 drainer "$pkgdir"/usr/bin
+ install -Dm755 sync_diff_inspector "$pkgdir"/usr/bin
}
for _p in ${pkgname[@]}; do