summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2018-04-19 17:17:11 +0800
committerAllen Zhong2018-04-19 17:17:11 +0800
commitb1ab51207da83cda6408fc9c92a0e0f764926e10 (patch)
treef88abd7589e97625f3e4e8244832f92c21fa4551
parent3e3bbf8478ef49db81a386f05a945901ff7bda28 (diff)
downloadaur-b1ab51207da83cda6408fc9c92a0e0f764926e10.tar.gz
bump to 2.0.0-rc6
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD18
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf0788693023..7448af899ed5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Feb 25 17:34:45 UTC 2018
+# Thu Apr 19 09:08:31 UTC 2018
pkgbase = tidb-bin
pkgdesc = A distributed NewSQL database compatible with MySQL protocol
- pkgver = 1.0.8
+ pkgver = 2.0.0.rc6
pkgrel = 1
url = https://github.com/pingcap/tidb
arch = x86_64
license = APACHE
depends = gcc-libs
- source = https://download.pingcap.org/tidb-v1.0.8-linux-amd64.tar.gz
- sha256sums = 09846174db2c16421000e89e60e1e64a50613a0a11708abffb69f93f11a6f711
+ options = strip
+ options = debug
+ source = https://download.pingcap.org/tidb-v2.0.0-rc.6-linux-amd64.tar.gz
+ sha256sums = 3ef3ebd6cfd9a4ae471fef37819b7ca1be3576b6041eddc190622ccaa6b61b8c
pkgname = tidb-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1b2f91ef9bef
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.gz
+*.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 76b612ea646c..7fdf5df75130 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
-# Collaborator: Liqueur Librazy <im@librazy.org>
-# Maintainer: Jian Zeng <anonymousknight96@gmail.com>
+# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Liqueur Librazy <im@librazy.org>
+# Contributor: Jian Zeng <anonymousknight96@gmail.com>
pkgname=tidb-bin
-pkgver=1.0.8
+_basever=2.0.0
+_rcver=6
+pkgver=$_basever.rc$_rcver
pkgrel=1
pkgdesc="A distributed NewSQL database compatible with MySQL protocol"
@@ -10,12 +13,13 @@ url="https://github.com/pingcap/tidb"
license=('APACHE')
depends=('gcc-libs')
conflict=('tidb-bin-nightly')
-source=("https://download.pingcap.org/tidb-v$pkgver-linux-amd64.tar.gz")
-sha256sums=('09846174db2c16421000e89e60e1e64a50613a0a11708abffb69f93f11a6f711')
+options=(strip debug)
+source=("https://download.pingcap.org/tidb-v$_basever-rc.$_rcver-linux-amd64.tar.gz")
+sha256sums=('3ef3ebd6cfd9a4ae471fef37819b7ca1be3576b6041eddc190622ccaa6b61b8c')
package() {
- cd "tidb-v$pkgver-linux-amd64/bin" || exit 1
+ cd "tidb-v$_basever-rc.$_rcver-linux-amd64/bin" || exit 1
for i in ti* pd-*; do
- install -D -m755 "$i" "$pkgdir/usr/bin/$i"
+ install -Dm755 "$i" "$pkgdir/usr/bin/$i"
done
}