summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2018-04-19 18:09:36 +0800
committerAllen Zhong2018-04-19 18:09:36 +0800
commitff7280671b98bdabaccb1b51f29fb2e849f9bbf7 (patch)
treef9cb03e0d621ff08a5d0d50814681cd616c379c8
parent61472bd98940695fd1965e09b26b0fcc43a91714 (diff)
downloadaur-ff7280671b98bdabaccb1b51f29fb2e849f9bbf7.tar.gz
adjust provides and optdepends
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b99f8f26592b..0c90aaeddeae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
# Generated by mksrcinfo v8
-# Thu Apr 19 09:54:45 UTC 2018
+# Thu Apr 19 10:08:55 UTC 2018
pkgbase = tidb-bin
pkgdesc = A distributed NewSQL database compatible with MySQL protocol
pkgver = 2.0.0.rc6
pkgrel = 2
url = https://github.com/pingcap/tidb
- install = tidb.install
arch = x86_64
license = APACHE
depends = gcc-libs
- optdepends = go-tools: provides goyacc
- provides = tidb=2.0.0
conflicts = tidb-bin-nightly
options = strip
options = debug
@@ -22,6 +19,9 @@ pkgbase = tidb-bin
sha256sums = 15f285782938b3ebbb8be60cc962a2cbf5ca349527c39d3a1138be1bf976feb9
pkgname = tidb-bin
+ install = tidb.install
+ provides = tidb=2.0.0
pkgname = tidb-bin-utils
+ optdepends = go-tools: provides goyacc
diff --git a/PKGBUILD b/PKGBUILD
index 0c28302ef819..01c97ea63951 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Allen Zhong <moeallenz@gmail.com>
-# Contributor: Liqueur Librazy <im@librazy.org>
+# Maintainer: Liqueur Librazy <im@librazy.org>
# Contributor: Jian Zeng <anonymousknight96@gmail.com>
pkgbase=tidb-bin
_basever=2.0.0
@@ -12,10 +12,7 @@ arch=('x86_64')
url="https://github.com/pingcap/tidb"
license=('APACHE')
depends=('gcc-libs')
-optdepends=('go-tools: provides goyacc')
-provides=("tidb=$_basever")
conflicts=('tidb-bin-nightly')
-install='tidb.install'
options=('strip' 'debug')
source=("https://download.pingcap.org/tidb-v$_basever-rc.$_rcver-linux-amd64.tar.gz"
"tidb.sysusers"
@@ -26,6 +23,8 @@ sha256sums=('3ef3ebd6cfd9a4ae471fef37819b7ca1be3576b6041eddc190622ccaa6b61b8c'
'15f285782938b3ebbb8be60cc962a2cbf5ca349527c39d3a1138be1bf976feb9')
_package() {
+ provides=("tidb=$_basever")
+ install='tidb.install'
cd "$srcdir"
install -Dm644 tidb.sysusers "$pkgdir"/usr/lib/sysusers.d/tidb.conf
install -Dm644 tidb.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/tidb.conf
@@ -36,6 +35,7 @@ _package() {
}
_package-utils() {
+ optdepends=('go-tools: provides goyacc')
cd "tidb-v$_basever-rc.$_rcver-linux-amd64/bin"
install -dm755 "$pkgdir"/usr/bin
install -Dm755 *-ctl "$pkgdir"/usr/bin