summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2015-09-08 12:42:02 +0200
committerMassimiliano Torromeo2015-09-08 12:42:02 +0200
commit76266a59bff7ac36fe233e701e8ef0d86a26431d (patch)
treebcc1d94caaeb4ecbfd01f90fd10bf031f5f23383
downloadaur-76266a59bff7ac36fe233e701e8ef0d86a26431d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD54
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2332b61f2779
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tidb-git
+ pkgdesc = Distributed SQL database inspired by the desing of Google F1
+ pkgver = 8920a55
+ pkgrel = 1
+ url = https://github.com/pingcap/tidb
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = go
+ makedepends = godep
+ depends = glibc
+ source = git+https://github.com/pingcap/tidb.git
+ sha256sums = SKIP
+
+pkgname = tidb-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a8e45f85b33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=tidb-git
+pkgver=8920a55
+pkgrel=1
+pkgdesc="Distributed SQL database inspired by the desing of Google F1"
+arch=('i686' 'x86_64')
+url="https://github.com/pingcap/tidb"
+license=('APACHE')
+depends=('glibc')
+makedepends=('go' 'godep')
+source=(git+https://github.com/pingcap/tidb.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/tidb"
+ git describe --tags --always | sed 's|-|.|g'
+}
+
+prepare() {
+ mkdir -p src/github.com/pingcap
+ cd src/github.com/pingcap
+ rm -f tidb
+ ln -s "$srcdir/tidb"
+}
+
+build() {
+ export GOPATH="$srcdir"
+ export PATH="$PATH:$GOPATH/bin"
+ cd src/github.com/pingcap/tidb
+
+ make parser
+ go get -v
+ make build
+}
+
+check() {
+ export GOPATH="$srcdir"
+ export PATH="$PATH:$GOPATH/bin"
+ cd src/github.com/pingcap/tidb
+
+ make test
+}
+
+package() {
+ export GOPATH="$srcdir"
+ export PATH="$PATH:$GOPATH/bin"
+ cd src/github.com/pingcap/tidb
+
+ make install
+
+ cd "$GOPATH"/bin
+ install -Dm755 interpreter "$pkgdir"/usr/bin/tidb
+}