summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorliyp2023-03-09 14:14:40 +0800
committerliyp2023-03-09 14:14:40 +0800
commitc1e57395c8f52b60964cf7e07fd53b81a6bc4b78 (patch)
tree01790f6075188256c07e5ef0239c8a35028938db
parentad17cdaa1166f4fccde681dd427916d255b0dbce (diff)
downloadaur-c1e57395c8f52b60964cf7e07fd53b81a6bc4b78.tar.gz
delete unneeded file
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fefe53fddccd..2ec87a38d415 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tidgi-bin
pkgdesc = Customizable personal knowledge-base with Github as unlimited storage and blogging platform.
pkgver = 0.7.14
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tiddly-gittly/TidGi-Desktop
arch = i686
arch = x86_64
@@ -43,13 +43,12 @@ pkgbase = tidgi-bin
depends = trash-cli
depends = xdg-utils
depends = zlib
- options = !strip
- options = !emptydirs
+ conflicts = tidgi
source_i686 = https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v0.7.14/tidgi_0.7.14_amd64.deb
sha512sums_i686 = 280b5dc53c3d553855bb886f0798da19aed745653fbe53d8ae479df74da72ddce5cc0affb9ef05dd19f761221cc178567426a634dcd551508908861e9ca21490
source_x86_64 = https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v0.7.14/tidgi_0.7.14_amd64.deb
sha512sums_x86_64 = 280b5dc53c3d553855bb886f0798da19aed745653fbe53d8ae479df74da72ddce5cc0affb9ef05dd19f761221cc178567426a634dcd551508908861e9ca21490
- source_aarch64 = https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v0.7.14}/tidgi_0.7.14_arm64.deb
+ source_aarch64 = https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v0.7.14/tidgi_0.7.14_arm64.deb
sha512sums_aarch64 = 22de9a3cbf8b5922d7fdc689232425f96b4cf52b65c3c584781f29e7e0863b3b6047f449876607f664dec7d8ab152d173a3a25c225bb7754625552499f25b303
pkgname = tidgi-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8d6001a74fc1..b03fc67dee7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,21 @@
pkgname=tidgi-bin
_pkgname=tidgi
pkgver=0.7.14
-pkgrel=1
+conflicts=('tidgi')
+pkgrel=2
pkgdesc="Customizable personal knowledge-base with Github as unlimited storage and blogging platform."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/tiddly-gittly/TidGi-Desktop"
+
license=('MPL2')
+
depends=('nodejs' 'alsa-lib' 'atk' 'at-spi2-atk' 'at-spi2-core' 'cairo' 'curl' 'dbus' 'desktop-file-utils' 'expat' 'gdk-pixbuf2' 'glib2' 'gtk3' 'gvfs' 'hicolor-icon-theme' 'libcups' 'libdrm' 'libnotify' 'libx11' 'libxcb' 'libxcomposite' 'libxdamage' 'libxext' 'libxfixes' 'libxkbcommon' 'libxrandr' 'libxtst' 'mesa' 'nspr' 'nss' 'openssl' 'pango' 'trash-cli' 'xdg-utils' 'zlib')
+
makedepends=('zstd')
-options=('!strip' '!emptydirs')
-#install=${pkgname}.install
+
source_i686=("https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
source_x86_64=("https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
-source_aarch64=("https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v${pkgver}}/${_pkgname}_${pkgver}_arm64.deb")
+source_aarch64=("https://github.com/tiddly-gittly/TidGi-Desktop/releases/download/v${pkgver}/${_pkgname}_${pkgver}_arm64.deb")
sha512sums_i686=('280b5dc53c3d553855bb886f0798da19aed745653fbe53d8ae479df74da72ddce5cc0affb9ef05dd19f761221cc178567426a634dcd551508908861e9ca21490')
sha512sums_x86_64=('280b5dc53c3d553855bb886f0798da19aed745653fbe53d8ae479df74da72ddce5cc0affb9ef05dd19f761221cc178567426a634dcd551508908861e9ca21490')
sha512sums_aarch64=('22de9a3cbf8b5922d7fdc689232425f96b4cf52b65c3c584781f29e7e0863b3b6047f449876607f664dec7d8ab152d173a3a25c225bb7754625552499f25b303')
@@ -23,7 +26,8 @@ package(){
# Extract package data
tar --zstd -xvf data.tar.zst --directory "${pkgdir}"
cd "${pkgdir}"
- install -D -m644 "usr/lib/tidgi/resources/node_modules/zx/node_modules/yaml/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 "usr/share/doc/tidgi/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+ install -D -m644 "${pkgdir}/usr/lib/tidgi/resources/node_modules/zx/node_modules/yaml/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "${pkgdir}/usr/share/doc/tidgi/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+ rm -rf "${pkgdir}/usr/share/lintian"
}