summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevome2024-01-13 15:26:11 +0800
committerdevome2024-01-13 15:26:11 +0800
commit9278621437e087614db4f30a9c71df521c650a97 (patch)
tree15a9869dda2a674a014e3c496af2c47d235baddd
downloadaur-9278621437e087614db4f30a9c71df521c650a97.tar.gz
tieba-cloud-sign: 20231124.154303-1
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--tieba-cloud-sign.crontab1
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c5dd2212754
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tieba-cloud-sign
+ pkgdesc = Baidu Tieba Cloud Sign | 百度贴吧云签到
+ pkgver = 20231124.074303
+ pkgrel = 1
+ url = https://github.com/MoeNetwork/Tieba-Cloud-Sign
+ arch = any
+ license = custom
+ depends = cronie
+ depends = mariadb
+ depends = php-fpm
+ optdepends = php-gd: image processing for generating verification codes | 图像处理,用于生成验证码
+ optdepends = caddy: reverse proxy php service | 代理 php webui 页面
+ optdepends = nginx: reverse proxy php service | 代理 php webui 页面
+ optdepends = traefik: reverse proxy php service | 代理 php webui 页面
+ source = tieba-cloud-sign::git+https://github.com/MoeNetwork/Tieba-Cloud-Sign
+ source = tieba-cloud-sign.crontab
+ sha256sums = SKIP
+ sha256sums = e12cea2de704c077dcbaa137d8bb25c3b166082c7b3e78d010517ea9822fdaba
+
+pkgname = tieba-cloud-sign
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d9c9c7892ddb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+tieba-cloud-sign
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..181ccbf7fdfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Evine Deng <evinedeng@hotmail.com>
+
+pkgname=tieba-cloud-sign
+pkgver=20231124.154303
+pkgrel=1
+pkgdesc="Baidu Tieba Cloud Sign | 百度贴吧云签到"
+arch=("any")
+url="https://github.com/MoeNetwork/Tieba-Cloud-Sign"
+license=("custom")
+depends=("cronie" "mariadb" "php-fpm")
+optdepends=("php-gd: image processing for generating verification codes | 图像处理,用于生成验证码"
+ "caddy: reverse proxy php service | 代理 php webui 页面"
+ "nginx: reverse proxy php service | 代理 php webui 页面"
+ "traefik: reverse proxy php service | 代理 php webui 页面")
+source=("${pkgname}::git+${url}"
+ "${pkgname}.crontab")
+sha256sums=('SKIP'
+ 'e12cea2de704c077dcbaa137d8bb25c3b166082c7b3e78d010517ea9822fdaba')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "$(git log -1 --format="%cd" --date='format:%Y%m%d.%H%M%S')"
+}
+
+package() {
+ install -Dm644 "${pkgname}.crontab" "${pkgdir}/etc/cron.d/${pkgname}"
+
+ rm -rf "${pkgname}/"{.git,.gitignore,.github,docker}
+ mv "${pkgname}/config.php" "${pkgname}/config.php.example"
+ find "${pkgname}" -type d -exec chmod 755 {} \;
+ find "${pkgname}" -type f -exec chmod 644 {} \;
+
+ install -dm755 "${pkgdir}/srv"
+ cp -r "${pkgname}" "${pkgdir}/srv/${pkgname}"
+}
diff --git a/tieba-cloud-sign.crontab b/tieba-cloud-sign.crontab
new file mode 100644
index 000000000000..03a2edcd1e64
--- /dev/null
+++ b/tieba-cloud-sign.crontab
@@ -0,0 +1 @@
+* * * * * root /usr/bin/php /srv/tieba-cloud-sign/do.php &>/dev/null