summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHansruedi Patzen2018-10-09 09:19:57 +0200
committerHansruedi Patzen2018-10-09 09:19:57 +0200
commit98d7c5737c0e3710b4f78162276c535ebc90925f (patch)
tree06e7e184205f4816cccddec4ba1b04ae25e5c9c5
parent425b4ae6debae3ec454f6960b6d5688691aca6d7 (diff)
downloadaur-98d7c5737c0e3710b4f78162276c535ebc90925f.tar.gz
update pkgver
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c11d0216b94d..dcd5b8c062cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = tifig
pkgdesc = Swift IDE based on Eclipse
- pkgver = 0.8.0.2017123002054
- pkgrel = 1
+ pkgver = 0.8.0
+ pkgrel = 2
url = https://www.tifig.net/
arch = x86_64
- license = custom:CC-BY-SA-4.0
+ license = custom:cc-by-sa-4.0
depends = swift
depends = java-environment>=8
depends = python
@@ -12,7 +12,7 @@ pkgbase = tifig
conflicts = tifig
options = emptydirs
source = LICENSE
- source = tifig-0.8.0.2017123002054-x86_64.tar.gz::https://tifig-downloads.s3.amazonaws.com/tifig-0.8.0-201712302054-linux.gtk.x86_64.tar.gz
+ source = tifig-0.8.0-201712302054-x86_64.tar.gz::https://tifig-downloads.s3.amazonaws.com/tifig-0.8.0-201712302054-linux.gtk.x86_64.tar.gz
sha512sums = 6395618de74d4d432bb06175ceb8e16382f73613363b9409afebf7c5f59ab3ebd0f668fe0947f3a4b492afa8fa80146ba263470f2e2f4f10d51db328a559b9ac
sha512sums = 891de9a900c2f976ce216e8654ce8e9b29d35e1df62eb856b1b06bab2b92e76bc82db41499900b752a67dbe53e818bfb4920f2f101b0caebb43263db43987a77
diff --git a/PKGBUILD b/PKGBUILD
index abe48340792c..f74dc2068e3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Hansruedi Patzen <hp@revy.ch>
pkgname=tifig
-_execname=runner
-_basever=0.8.0
-_build=2017123002054
-pkgver=${_basever}.${_build}
-pkgrel=1
+_srctimestamp=201712302054
+pkgver=0.8.0
+pkgrel=2
provides=('tifig')
conflicts=('tifig')
pkgdesc='Swift IDE based on Eclipse'
arch=('x86_64')
url='https://www.tifig.net/'
-license=('custom:CC-BY-SA-4.0')
+license=('custom:cc-by-sa-4.0')
depends=('swift' 'java-environment>=8' 'python')
options=(emptydirs)
source=(
LICENSE
- ${pkgname}-${pkgver}-${CARCH}.tar.gz::'https://tifig-downloads.s3.amazonaws.com/tifig-0.8.0-201712302054-linux.gtk.x86_64.tar.gz'
+ ${pkgname}-${pkgver}-${_srctimestamp}-${CARCH}.tar.gz::"https://tifig-downloads.s3.amazonaws.com/${pkgname}-${pkgver}-${_srctimestamp}-linux.gtk.${CARCH}.tar.gz"
)
sha512sums=(
'6395618de74d4d432bb06175ceb8e16382f73613363b9409afebf7c5f59ab3ebd0f668fe0947f3a4b492afa8fa80146ba263470f2e2f4f10d51db328a559b9ac'
@@ -26,11 +24,12 @@ sha512sums=(
_libdir=/usr/lib/${pkgname}
_bindir=/usr/bin/${pkgname}
+_execname=runner
package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -d ${pkgdir}/${_libdir}
- bsdtar cf - --cd ${srcdir}/${pkgname}-${_basever} . | bsdtar xf - --cd ${pkgdir}/${_libdir}
+ bsdtar cf - --cd ${srcdir}/${pkgname}-${pkgver} . | bsdtar xf - --cd ${pkgdir}/${_libdir}
mv ${pkgdir}/${_libdir}/Tifig.ini ${pkgdir}/${_libdir}/${_execname}.ini
rm ${pkgdir}/${_libdir}/*.so.* ${pkgdir}/${_libdir}/detect-libc ${pkgdir}/${_libdir}/tifig.sh ${pkgdir}/${_libdir}/tifig.desktop
@@ -52,6 +51,6 @@ Categories=Development;IDE;Swift;
StartupNotify=true
END
- install -Dm644 "${srcdir}/${pkgname}-${_basever}/icon.xpm" "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/icon.xpm" "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
}