summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Ng2021-09-03 13:39:23 +0800
committerDarren Ng2021-09-03 13:39:23 +0800
commit83b6d75afc480de4ecebcb6b040aa1778de1cf7c (patch)
treea0d5986206c1f9e744c2ecb85f4e0a99e3d2b66b
parent97f2d808990c01f3b9d34c9a496c42cd8ff5a4a6 (diff)
downloadaur-83b6d75afc480de4ecebcb6b040aa1778de1cf7c.tar.gz
fix: dep libvips, compile err "numeric_limits is not a member of std"
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--01-limits.patch12
-rw-r--r--PKGBUILD29
4 files changed, 45 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4e900375ffd..f0b7ce727e37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = tifig-git
pkgdesc = A fast High Efficiency Image File Format (HEIF/HEIC) converter
- pkgver = r73.7dea067
+ pkgver = r83.60b920c
pkgrel = 1
url = https://github.com/monostream/tifig
arch = x86_64
license = Apache
makedepends = git
makedepends = cmake
- depends = ffmpeg
- depends = vips
+ depends = ffmpeg>=3.1
+ depends = libvips>=8.6
provides = tifig
conflicts = tifig
+ source = 01-limits.patch
source = git+https://github.com/monostream/tifig.git
source = git+https://github.com/monostream/heif.git
source = git+https://github.com/jarro2783/cxxopts.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ sha1sums = 2e095817eca65e4957f15520ef2559481d552c8c
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
pkgname = tifig-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1b33d53db642
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.patch
diff --git a/01-limits.patch b/01-limits.patch
new file mode 100644
index 000000000000..c8f7fe6cb7b8
--- /dev/null
+++ b/01-limits.patch
@@ -0,0 +1,12 @@
+diff --git a/include/cxxopts.hpp b/include/cxxopts.hpp
+index 17bb590..ecdb5b7 100644
+--- a/include/cxxopts.hpp
++++ b/include/cxxopts.hpp
+@@ -41,6 +41,7 @@ THE SOFTWARE.
+ #include <string>
+ #include <unordered_set>
+ #include <vector>
++#include <limits>
+
+ //when we ask cxxopts to use Unicode, help strings are processed using ICU,
+ //which results in the correct lengths being computed for strings when they
diff --git a/PKGBUILD b/PKGBUILD
index 432d7189051b..54aac0000a7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
# Maintainer: Batou <batou at cryptolab dot net>
+# Maintainer: Darren Ng <$(base64 --decode <<<VW4xR2ZuQGdtYWlsLmNvbQo=)>
pkgname=tifig-git
-pkgver=r73.7dea067
+pkgver=r83.60b920c
pkgrel=1
pkgdesc="A fast High Efficiency Image File Format (HEIF/HEIC) converter"
arch=('x86_64')
url="https://github.com/monostream/tifig"
license=('Apache')
-depends=('ffmpeg' 'vips')
+depends=('ffmpeg>=3.1' 'libvips>=8.6')
makedepends=('git' 'cmake')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(
+ '01-limits.patch'
'git+https://github.com/monostream/tifig.git'
'git+https://github.com/monostream/heif.git'
'git+https://github.com/jarro2783/cxxopts.git'
)
-md5sums=(
+sha1sums=(
+ '2e095817eca65e4957f15520ef2559481d552c8c'
'SKIP'
'SKIP'
'SKIP'
)
-pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd "$srcdir/${pkgname%-git}"
local submodules=(
@@ -37,13 +35,24 @@ prepare() {
git config "submodule.$submodule.url" "$srcdir/${submodule##*/}"
git submodule update "$submodule"
done
+ git apply --directory=lib/cxxopts/ "$srcdir/${source[0]}"
+}
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "$srcdir/${pkgname%-git}"
mkdir -p "build" && cd "build"
- cmake ..
- make
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=TRUE \
+ -Wno-dev
+ # printf "\ncd %s; cmake-gui ..\n\n" "$PWD"; return 1
+ make # VERBOSE=1
}
package() {