summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorheatingdevice2017-08-13 17:43:21 -0400
committerheatingdevice2017-08-13 17:47:08 -0400
commit169204607d082beef5066eb3cb598fe07136883c (patch)
treea5142edd6054e0e8947adfe2edeec32a68cd78b4
downloadaur-169204607d082beef5066eb3cb598fe07136883c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16585186b537
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tigcap
+ pkgdesc = A powerful screenshot tool
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/theimgguru/tigcap/
+ arch = x86_64
+ license = GPL
+ makedepends = npm
+ makedepends = nodejs
+ depends = imagemagick
+ optdepends = libnotify: Notification support
+ source = https://github.com/theimgguru/tigcap/archive/master.tar.gz
+ md5sums = de9009e57e57c59b11103542374c0fdd
+
+pkgname = tigcap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5339467d9dc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Heating Device <via DoT heatingdevice OT me DuT co m>
+pkgname=tigcap
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A powerful screenshot tool"
+arch=('x86_64')
+url="https://github.com/theimgguru/tigcap/"
+license=('GPL')
+groups=()
+depends=(imagemagick)
+makedepends=(npm nodejs)
+optdepends=('libnotify: Notification support')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/theimgguru/tigcap/archive/master.tar.gz)
+noextract=()
+md5sums=() #autofill using updpkgsums
+
+build() {
+ cd "$pkgname-master"
+
+ npm install
+}
+
+package() {
+ cd "$pkgname-master"
+
+ node_modules/.bin/electron-packager . TIGCap --no-prune --out out --asar --overwrite
+ mkdir -p $pkgdir/opt/tigcap
+
+ cp -dr --no-preserve=ownership out/TIGCap-linux-*/* "$pkgdir/opt/tigcap"
+ mkdir -p "$pkgdir/usr/share/applications"
+ install TIGCap.desktop "$pkgdir/usr/share/applications"
+}
+md5sums=('de9009e57e57c59b11103542374c0fdd')