summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:08:10 +0100
committerSteven Honeyman2015-06-09 19:08:10 +0100
commit76dd7c599beb21c66c4d295b53aba3fabcd4bcc3 (patch)
treecce6b20e939c09c6f02926a55bf207c2da81892e
downloadaur-76dd7c599beb21c66c4d295b53aba3fabcd4bcc3.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--vncviewer.desktop10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d807c396d809
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tigervnc-viewer
+ pkgdesc = TigerVNC (Viewer only), forked from the VNC 4 branch of TightVNC.
+ pkgver = 1.3.1
+ pkgrel = 2
+ url = http://www.tigervnc.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = fltk
+ depends = gnutls
+ depends = libjpeg-turbo
+ conflicts = tightvnc
+ options = strip
+ source = http://downloads.sourceforge.net/project/tigervnc/tigervnc/1.3.1/tigervnc-1.3.1.tar.gz
+ source = vncviewer.desktop
+ md5sums = e80b16aa74f1d8e89f284a6aef99955d
+ md5sums = 71cac0fb9701b0a041430f0fddfe00c8
+
+pkgname = tigervnc-viewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c47b6bcbeaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=tigervnc-viewer
+pkgver=1.3.1
+pkgrel=2
+pkgdesc="TigerVNC (Viewer only), forked from the VNC 4 branch of TightVNC."
+arch=('i686' 'x86_64')
+url="http://www.tigervnc.org"
+license=('GPL')
+options=('strip')
+depends=('fltk' 'gnutls' 'libjpeg-turbo')
+makedepends=('cmake')
+conflicts=('tightvnc')
+source=(http://downloads.sourceforge.net/project/tigervnc/tigervnc/$pkgver/tigervnc-$pkgver.tar.gz
+ vncviewer.desktop)
+md5sums=('e80b16aa74f1d8e89f284a6aef99955d'
+ '71cac0fb9701b0a041430f0fddfe00c8')
+
+build() {
+ cd ${srcdir}/tigervnc-${pkgver}
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr
+ cd vncviewer
+ make
+}
+
+package() {
+ cd ${srcdir}/tigervnc-${pkgver}
+ mv vncviewer/vncviewer.man vncviewer.1 && gzip -9 vncviewer.1
+
+ install -Dm755 vncviewer/vncviewer $pkgdir/usr/bin/vncviewer
+ install -Dm644 $srcdir/vncviewer.desktop $pkgdir/usr/share/applications/vncviewer.desktop
+ install -Dm644 vncviewer.1.gz $pkgdir/usr/share/man/man1/vncviewer.1.gz
+
+ for i in 16 22 24 32 48; do
+ install -Dm644 media/icons/tigervnc_${i}.png ${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/tigervnc.png
+ done
+}
diff --git a/vncviewer.desktop b/vncviewer.desktop
new file mode 100644
index 000000000000..5f6046db2bba
--- /dev/null
+++ b/vncviewer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=TigerVNC viewer
+Comment=TigerVNC viewer
+Exec=/usr/bin/vncviewer
+Icon=tigervnc.png
+Terminal=false
+StartupNotify=false
+Categories=Application; Network;